summaryrefslogtreecommitdiff
path: root/net-wireless
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/Manifest.gzbin13889 -> 13883 bytes
-rw-r--r--net-wireless/blueman/Manifest2
-rw-r--r--net-wireless/blueman/blueman-2.4.4.ebuild174
3 files changed, 176 insertions, 0 deletions
diff --git a/net-wireless/Manifest.gz b/net-wireless/Manifest.gz
index a9dd55ea80f2..7391ff6dc321 100644
--- a/net-wireless/Manifest.gz
+++ b/net-wireless/Manifest.gz
Binary files differ
diff --git a/net-wireless/blueman/Manifest b/net-wireless/blueman/Manifest
index 1d70aabbd157..2d59bc911037 100644
--- a/net-wireless/blueman/Manifest
+++ b/net-wireless/blueman/Manifest
@@ -1,5 +1,7 @@
AUX 01-org.blueman.rules 432 BLAKE2B c81ec47bc68be911b44056e4f0f4dd4e2939d8d5db78fbca9f4ddceb7c8ed0108bff1bc12d83ebfa9ed67f8939fdd0aea712aec4ae964f10d84a4a6077479a37 SHA512 5cea5f5e9f43e9778dd671ecfdf59e79d740abf278cd9a7250efcf790f632d9ff6b08bf82dff96292c45c3424be9dc290bb39c3bf329c853e02e0ae3f7bb213b
DIST blueman-2.4.3.tar.xz 1567044 BLAKE2B 1ecd7e70ab5e84e68115cdfc6a6dbdcaa539973fc4fd93740495c822a0b08b1fc2e9fd46b421282fd0ba4a4ce5deccef6724e7fa23466b9c68d9523eacfecd97 SHA512 387e51d143b90ee34d156595f83d032930e427baee4065cb07809b8273f4da641893caa4113cc034c81bfacdb9b2caffb316b6d8738a44aba90ca6941aefc13f
+DIST blueman-2.4.4.tar.xz 1633652 BLAKE2B b83bec9ec2e51fec0897ed43e1853759c5164747a78e600c3397d2b05297b41c0976237af1d3a4897d7ddabd87d9b9feb29bd8767400b6abcb9fc6ddbac92f09 SHA512 319f2ccf253decf003731ecbbf93bb50685589c4a4a954ae848a09998583d85ce608a38bdfa37d81d3ebd5172b428063e0b4c6a30b1bab53c8419f597d2a2fa8
EBUILD blueman-2.4.3.ebuild 3673 BLAKE2B 81d5a5f8fc846bc9e473fec38114ce5d643d04408dcc155f5f51c9f3b82dbfb2e9eb0de09ab1df4f5195c38582c13efbb2174ac9e1908dfc28df6124ce409a4b SHA512 f16df96bcc82004267a882bfcd3aabecf4c38a57927b41b30294e25407894c079c821bddbb4f5d39e752799cf5fefc04f8bd3351b5cf1191fd09ab9cc9239a21
+EBUILD blueman-2.4.4.ebuild 3679 BLAKE2B 8ff4ff7147d78c5896b909a8bde023a6311933cd47c4e737a73ae2577b8a350117e30198c25afab63ff85598f88fc28c2f47cd453341c63841ecf70006ae3128 SHA512 ada1fc7e047a3e9b787f9db3918b411b460e5b4d0f2346d2ab26bb5d7a78802fd3faefc36ab7d8e0aa221e2eaa6a5b52b5be38b7fb2e163a1ecaf4b86deac71f
EBUILD blueman-9999.ebuild 3683 BLAKE2B 4b372b960cefbc6d1735d52136e2da7b30aa11c3236f17379e627819c53d1f886ad2fcf48125ed4f13b176b65c2290f989948a82f99819ea6011ed66552e2a75 SHA512 7dea4884ef5d285481d10062bdbe7bd8f9363b551dbee59a2f9c30c658627111718093679a7eb0f3f9d7fd2d5f3e2dbb506350aa186848b77fb16d5d946ce597
MISC metadata.xml 499 BLAKE2B 54e6fc4cc7b9922abf5a8bae572c282bded5bce21add03e418effeb5009ce7700a3fbede5f132638aa934b71b0898310e1b8315c48a76216045d56e53c7cf1dc SHA512 30e120ce07c4b4bfc278dfcfcad987bf878ed1ebc0ec92d859cf943270c439cdf717b5a9f01ee36399a64743c98aa73f9cd91db4fc85e0c0cf6b73c75d62a817
diff --git a/net-wireless/blueman/blueman-2.4.4.ebuild b/net-wireless/blueman/blueman-2.4.4.ebuild
new file mode 100644
index 000000000000..8502df3fcefb
--- /dev/null
+++ b/net-wireless/blueman/blueman-2.4.4.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit autotools distutils-r1 gnome2-utils linux-info systemd xdg-utils
+
+DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
+HOMEPAGE="https://github.com/blueman-project/blueman/"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
+else
+ SRC_URI="
+ https://github.com/blueman-project/blueman/releases/download/${PV/_/.}/${P/_/.}.tar.xz
+ "
+ S=${WORKDIR}/${P/_/.}
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+# icons are GPL-2
+# source files are mixed GPL-3+ and GPL-2+
+LICENSE="GPL-3+ GPL-2"
+SLOT="0"
+IUSE="network nls policykit pulseaudio"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ >=net-wireless/bluez-5:=
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ media-libs/libpulse
+ >=net-misc/networkmanager-0.8[introspection]
+ )
+ ')
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ ')
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection,X]
+ x11-libs/libnotify[introspection]
+ || (
+ x11-themes/adwaita-icon-theme
+ x11-themes/faenza-icon-theme
+ x11-themes/mate-icon-theme
+ )
+ network? (
+ net-firewall/iptables
+ || (
+ sys-apps/net-tools
+ sys-apps/iproute2
+ )
+ || (
+ net-dns/dnsmasq
+ net-misc/dhcp
+ >=net-misc/networkmanager-0.8[introspection]
+ )
+ )
+ policykit? (
+ sys-auth/polkit
+ )
+ pulseaudio? (
+ || (
+ media-sound/pulseaudio-daemon[bluetooth]
+ media-video/pipewire[bluetooth]
+ <media-sound/pulseaudio-15.99.1[bluetooth]
+ )
+ )
+"
+
+distutils_enable_tests unittest
+
+pkg_pretend() {
+ if use network; then
+ local CONFIG_CHECK="
+ ~BRIDGE
+ ~IP_NF_IPTABLES
+ ~IP_NF_NAT
+ ~IP_NF_TARGET_MASQUERADE
+ "
+ check_extra_config
+ fi
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Run else fails on newer automake: https://bugs.gentoo.org/936065
+ eautoreconf
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ local myconf=(
+ --disable-runtime-deps-check
+ --disable-static
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --with-dhcp-config="/etc/dhcp/dhcpd.conf"
+ $(use_enable policykit polkit)
+ $(use_enable nls)
+ $(use_enable pulseaudio)
+ # thunar integration is a single data file with no extra deps
+ # so install it unconditionally
+ --enable-thunar-sendto
+ )
+ econf "${myconf[@]}"
+}
+
+python_compile() {
+ default
+}
+
+python_test() {
+ local -x PYTHONPATH=module/.libs
+
+ if [[ ! -f /dev/rfkill ]]; then
+ # Tests attempt to import these modules if present, but they
+ # require /dev/rfkill. Hide them to make the tests pass.
+ mv blueman/plugins/mechanism/RfKill.py{,~} || die
+ mv blueman/plugins/applet/KillSwitch.py{,~} || die
+ fi
+
+ local failed=
+ nonfatal eunittest || failed=1
+
+ if [[ ! -f /dev/rfkill ]]; then
+ mv blueman/plugins/mechanism/RfKill.py{~,} || die
+ mv blueman/plugins/applet/KillSwitch.py{~,} || die
+ fi
+
+ [[ ${failed} ]] && die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ default
+
+ if use policykit; then
+ # Allow users in plugdev group to modify connections
+ insinto /usr/share/polkit-1/rules.d
+ doins "${FILESDIR}/01-org.blueman.rules"
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}