summaryrefslogtreecommitdiff
path: root/sci-astronomy/sirilic/sirilic-1.15.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/sirilic/sirilic-1.15.2.ebuild')
-rw-r--r--sci-astronomy/sirilic/sirilic-1.15.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-astronomy/sirilic/sirilic-1.15.2.ebuild b/sci-astronomy/sirilic/sirilic-1.15.2.ebuild
new file mode 100644
index 000000000000..ddd39e6922ea
--- /dev/null
+++ b/sci-astronomy/sirilic/sirilic-1.15.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Preparing acquisition files for processing with the SiriL software"
+HOMEPAGE="https://gitlab.com/free-astro/sirilic"
+SRC_URI="https://gitlab.com/free-astro/sirilic/-/archive/V${PV}/${PN}-V${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-V${PV}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-python/wxpython-4.2:4.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"