summaryrefslogtreecommitdiff
path: root/sci-astronomy/skymaker
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/skymaker')
-rw-r--r--sci-astronomy/skymaker/Manifest3
-rw-r--r--sci-astronomy/skymaker/files/skymaker-3.10.5-fno-common.patch66
-rw-r--r--sci-astronomy/skymaker/skymaker-3.10.5.ebuild10
3 files changed, 74 insertions, 5 deletions
diff --git a/sci-astronomy/skymaker/Manifest b/sci-astronomy/skymaker/Manifest
index 87d9c6f3a45c..994a7112bd50 100644
--- a/sci-astronomy/skymaker/Manifest
+++ b/sci-astronomy/skymaker/Manifest
@@ -1,3 +1,4 @@
+AUX skymaker-3.10.5-fno-common.patch 1719 BLAKE2B 473656de5281f6c4aaf06dd02a0d35f06e82edc329e68c6a5de0d8f8c75dff2127345b349c81fdc697268ba56f0f622faeea10ff791abf98d9b81bcbea2c4617 SHA512 21370919be5e4f1737fa2cbab0b25e889be2ed25a9152154270adcec53db18af040eb658bc7541622c57450b90b9415c16a4c8bfa7053f2221c91373f853e280
DIST skymaker-3.10.5.tar.gz 508938 BLAKE2B 82baaf083deb941c31052c3394a601489cb9c4efea979055236eb33af1df2b5473bc43339e76de0785956f5a9a7968f48c62227c66bf1e76ef57907e16cbdac4 SHA512 98bb5a75c21475c6ecf16cb7de333db7faae95fd32c4ac311b44ddf637ffec2c80061b056b070b8d21b1a5a46c0a5a82855e417d25a9d8de02aad2167cb45b43
-EBUILD skymaker-3.10.5.ebuild 478 BLAKE2B cfa9767c79c076a7c46b3d3a9e1f7a529e5cd63d152581e29db782a293386203d07a8c379cb85b5e3a762fbfd9540959a2f7904e887c64470d46451c0b8ff5c3 SHA512 8b5718b7f30c6ee93cd100085db033c9f3f348b71596cc768d7002cf4e46f7a872ac280472b10d788cfe2bfde8e55b7205f974c753060136bdcfc2ed76de75c4
+EBUILD skymaker-3.10.5.ebuild 525 BLAKE2B 7cc392bfc66c99ed270f3380f69140d96daf868b01cf9b55c5f1f1cd595b3bf138fb0d32a07c0fac856a69b4b9557a1d3c04d67eecb8358deff805c6ca373556 SHA512 141e468835c705945ed246cd6f00db1839e8e396253312bfa6672572123027e5346f13a1184f2596bb25d83645a23da7defed931e86b5948d2b8d80ff61518be
MISC metadata.xml 643 BLAKE2B 95eb978f8750015d33ffd6f62095d925e707b61b52e04f0e77b0016c6e579bf47ba5044d661b5d2bd9667d43ad4b4593518522f855bf2fbfca44953450b5fe3a SHA512 e96b76eb34dacad52e05f916ea8c6dafe9e1204bfbcfd3e24c791d179dcaaee6287aba5f81bfe4d922444a988df48ab4113883e5174b7d3e40c18e299b78c9da
diff --git a/sci-astronomy/skymaker/files/skymaker-3.10.5-fno-common.patch b/sci-astronomy/skymaker/files/skymaker-3.10.5-fno-common.patch
new file mode 100644
index 000000000000..f80ed5422c67
--- /dev/null
+++ b/sci-astronomy/skymaker/files/skymaker-3.10.5-fno-common.patch
@@ -0,0 +1,66 @@
+--- a/src/fits/fitscat.c
++++ b/src/fits/fitscat.c
+@@ -42,6 +42,9 @@
+ #include "fitscat_defs.h"
+ #include "fitscat.h"
+
++int bswapflag;
++char gstr[MAXCHAR];
++
+ /****** about_cat **************************************************************
+ PROTO int about_cat(catstruct *cat, FILE *stream)
+ PURPOSE Print some info about a catalog.
+--- a/src/fits/fitscat_defs.h
++++ b/src/fits/fitscat_defs.h
+@@ -86,7 +86,7 @@
+ typedef int LONG; /* for DEC-Alpha... */
+
+ /*----------------------------- Internal constants --------------------------*/
+-char gstr[MAXCHAR];
++extern char gstr[MAXCHAR];
+
+ /*----------------------------- External constants --------------------------*/
+
+--- a/src/fits/fitscat.h
++++ b/src/fits/fitscat.h
+@@ -333,6 +333,6 @@
+ warning(char *msg1, char *msg2);
+
+
+-int bswapflag;
++extern int bswapflag;
+
+ #endif
+--- a/src/globals.h
++++ b/src/globals.h
+@@ -29,7 +29,7 @@
+ #include "types.h"
+
+ /*----------------------- miscellaneous variables ---------------------------*/
+-char gstr[MAXCHAR];
++extern char gstr[MAXCHAR];
+
+ /*------------------------------- functions ---------------------------------*/
+ extern void makeit(void);
+--- a/src/prefs.c
++++ b/src/prefs.c
+@@ -59,6 +59,8 @@
+ #include "prefs.h"
+ #include "preflist.h"
+
++prefstruct prefs;
++
+ /********************************* dumpprefs ********************************/
+ /*
+ Print the default preference parameters.
+--- a/src/prefs.h
++++ b/src/prefs.h
+@@ -149,7 +149,7 @@
+ int nobj; /* Number of sources added */
+ } prefstruct;
+
+-prefstruct prefs;
++extern prefstruct prefs;
+
+ /*-------------------------------- protos -----------------------------------*/
+ extern int cistrcmp(char *cs, char *ct, int mode);
diff --git a/sci-astronomy/skymaker/skymaker-3.10.5.ebuild b/sci-astronomy/skymaker/skymaker-3.10.5.ebuild
index da9788d145b4..dd5c6c6a1882 100644
--- a/sci-astronomy/skymaker/skymaker-3.10.5.ebuild
+++ b/sci-astronomy/skymaker/skymaker-3.10.5.ebuild
@@ -1,20 +1,22 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Program that simulates astronomical images"
HOMEPAGE="http://www.astromatic.net/software/skymaker"
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="threads"
-RDEPEND="sci-libs/fftw:3.0"
+RDEPEND="sci-libs/fftw:3.0="
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_configure() {
econf $(use_enable threads)
}