summaryrefslogtreecommitdiff
path: root/sci-astronomy/stuff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/stuff')
-rw-r--r--sci-astronomy/stuff/Manifest3
-rw-r--r--sci-astronomy/stuff/files/stuff-1.26.0-fno-common.patch60
-rw-r--r--sci-astronomy/stuff/stuff-1.26.0.ebuild9
3 files changed, 66 insertions, 6 deletions
diff --git a/sci-astronomy/stuff/Manifest b/sci-astronomy/stuff/Manifest
index 5e4ccdacf436..96cf57c890d0 100644
--- a/sci-astronomy/stuff/Manifest
+++ b/sci-astronomy/stuff/Manifest
@@ -1,3 +1,4 @@
+AUX stuff-1.26.0-fno-common.patch 1525 BLAKE2B ed896e97960aa8d9bd985b6db130e5896d231a09752a2d0b7d9ea8a3eb56e1dbdd07f5e37ebe4ebf1ddc2734bd6b2dd8099db0f6d70063d0af3ff160e6b0206f SHA512 27f94d19fedae7dd894647174d03b0e50c6e1f71ad6efde9a7109bfa7a40bc49a28c1b06a328e5741652712d345d6664a66c87e8c711b367d51d7a53c346b72e
DIST stuff-1.26.0.tar.gz 4110495 BLAKE2B ca2af60a1aad3d53035bd7fc9384170a5db58ddd872e29bfaaec70e96840cec1793223f2702d2b4d800ec11c0bc53ddde6d0780d6ba76ffe0d10e6c61b5d2a74 SHA512 6b71112e29d06807c8fc880bd33032a08810554afa563f27d5af19a45293b780ab0b7827ad84ad7942bed28fe3b03bb6c1fa3983667d1fbcbb467b32653203f2
-EBUILD stuff-1.26.0.ebuild 471 BLAKE2B a100574889ed464a65bc1e5cbe405ca507d3edf0bde61b9cdf5c5f374e9396a2199ee72c8a054304f0423c9ea07ad8cc93b3f1dcdf2b8f157b5db9db6a4f31f4 SHA512 264e61b267adca3c75b344a81687e5ddf2ea34a4002ec136e45c15d104ea1c781d1d59f24b756c4ff74e55e35e9567c8b577e71921b58e0ecfaf083e7efd150a
+EBUILD stuff-1.26.0.ebuild 485 BLAKE2B 303dc026ccd8c7fabdc855828a8196897e911f342e5595b70ceaffdc163e83fb67aca114b57351dcf3fd4ef8e942302791b421d7df371c68ae8a1a9504933ea5 SHA512 2ede2392e656a9996801040ec26f295e98b410483307cb1e1afcc0fb6afa46a5f10e424f134393fc74a49fb269bd5df9d197c4bd9a4004e9e8c9abdb567dffca
MISC metadata.xml 508 BLAKE2B 29a51333e4006e5ab5f8169b4962d24e827350a36204e1730a9a1f735cfda39ce832d21f13f6667890ae72b560fa87b9a912d6af8a51daf55eddd4dee7e9b54d SHA512 44ade9a770e3e3d81016ee2dd3cd0ce57b989afc2115d97b72a7ab12feb1f044b368639b26ee471abf9c7191f1855214b6fdd38d60f52cec49eba7e42468d147
diff --git a/sci-astronomy/stuff/files/stuff-1.26.0-fno-common.patch b/sci-astronomy/stuff/files/stuff-1.26.0-fno-common.patch
new file mode 100644
index 000000000000..bb02fa9e26fd
--- /dev/null
+++ b/sci-astronomy/stuff/files/stuff-1.26.0-fno-common.patch
@@ -0,0 +1,60 @@
+--- a/src/cosmo.c
++++ b/src/cosmo.c
+@@ -39,6 +39,11 @@
+ #include "cosmo.h"
+ #include "lf.h"
+
++char gstr[MAXCHAR];
++int bswapflag;
++
++double H, H0, OmegaM, OmegaL, deltaMH;
++
+ /******************************** cosmo_dconf ********************************/
+ /*
+ Conformal distance. Numerical integration along geodesic, allowing for a
+--- a/src/cosmo.h
++++ b/src/cosmo.h
+@@ -38,7 +38,7 @@
+
+ /*------------------------------ global variables ---------------------------*/
+
+-double H, H0, OmegaM, OmegaL, deltaMH;
++extern double H, H0, OmegaM, OmegaL, deltaMH;
+
+ /*-------------------------------- protos -----------------------------------*/
+
+--- a/src/globals.h
++++ b/src/globals.h
+@@ -29,8 +29,8 @@
+ #include "types.h"
+
+ /*----------------------- miscellaneous variables ---------------------------*/
+-char gstr[MAXCHAR];
+-int bswapflag;
++extern char gstr[MAXCHAR];
++extern int bswapflag;
+
+ /*------------------------------- functions ---------------------------------*/
+ extern void error(int, char *, char *),
+--- a/src/prefs.c
++++ b/src/prefs.c
+@@ -53,6 +53,8 @@
+ #include "prefs.h"
+ #include "preflist.h"
+
++prefstruct prefs;
++
+ /********************************* dumpprefs ********************************/
+ /*
+ Print the default preference parameters.
+--- a/src/prefs.h
++++ b/src/prefs.h
+@@ -136,7 +136,7 @@
+ double time_diff; /* Execution time */
+ } prefstruct;
+
+-prefstruct prefs;
++extern prefstruct prefs;
+
+ /*----------------------------- Internal constants --------------------------*/
+
diff --git a/sci-astronomy/stuff/stuff-1.26.0.ebuild b/sci-astronomy/stuff/stuff-1.26.0.ebuild
index cc672651f264..8c31f838acdf 100644
--- a/sci-astronomy/stuff/stuff-1.26.0.ebuild
+++ b/sci-astronomy/stuff/stuff-1.26.0.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Tool for automatic generation of astronomical catalogs"
HOMEPAGE="http://www.astromatic.net/software/stuff/"
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="threads"
-RDEPEND=""
-DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_configure() {
econf $(use_enable threads)