summaryrefslogtreecommitdiff
path: root/sci-biology/seqan/seqan-3.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/seqan/seqan-3.1.0.ebuild')
-rw-r--r--sci-biology/seqan/seqan-3.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-biology/seqan/seqan-3.1.0.ebuild b/sci-biology/seqan/seqan-3.1.0.ebuild
new file mode 100644
index 000000000000..fc9dd78e4233
--- /dev/null
+++ b/sci-biology/seqan/seqan-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ Sequence Analysis Library"
+HOMEPAGE="https://www.seqan.de/"
+SRC_URI="https://github.com/seqan/seqan3/releases/download/${PV}/seqan3-${PV}-Source.tar.xz"
+S="${WORKDIR}/seqan3-${PV}-Source"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="cpu_flags_x86_sse4_2"
+REQUIRED_USE="cpu_flags_x86_sse4_2"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-cpp/range-v3
+ dev-libs/cereal
+ sci-libs/lemon
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ cmake_src_install
+ dodoc -r doc/*
+}