summaryrefslogtreecommitdiff
path: root/sci-biology
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/Manifest.gzbin19016 -> 19018 bytes
-rw-r--r--sci-biology/bcftools/Manifest2
-rw-r--r--sci-biology/bcftools/bcftools-1.21.ebuild42
-rw-r--r--sci-biology/pysam/Manifest4
-rw-r--r--sci-biology/pysam/pysam-0.23.0.ebuild68
-rw-r--r--sci-biology/pysam/pysam-9999.ebuild43
-rw-r--r--sci-biology/samtools/Manifest2
-rw-r--r--sci-biology/samtools/samtools-1.21.ebuild47
8 files changed, 186 insertions, 22 deletions
diff --git a/sci-biology/Manifest.gz b/sci-biology/Manifest.gz
index f585da4b9704..90cc60347dff 100644
--- a/sci-biology/Manifest.gz
+++ b/sci-biology/Manifest.gz
Binary files differ
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
index 5ae9c11fe860..92a67fa3defd 100644
--- a/sci-biology/bcftools/Manifest
+++ b/sci-biology/bcftools/Manifest
@@ -1,5 +1,7 @@
DIST bcftools-1.19.tar.bz2 7906216 BLAKE2B 43e7ac0fc6ffcf837607fb2fbbd58a72106a89b018d1fd4b24db0eb854a9bf0efd0c7762fae84bf7f51226346777be646d134159ea48e3eb3df71799e9353a3f SHA512 a203c65fa58fca8fb5276e73ed8fc23dfd841e9dc05881304a8b91327d60ac3b5fcf5a55a1f1bab5647037f037ff30f2881791052f6e29cf38c646cbc947a746
DIST bcftools-1.20.tar.bz2 7883049 BLAKE2B 36bfd82c9500f384b75ef93242a5879123f7fd63c893c95a1ce5efbfa9396f2c1fd75025ea2dd48d37e7dc93426ffaffbb2f3c6bdf64128fbdd3af2a2f760b17 SHA512 c77294923a6bb5cb97a2c4947e79aa215612a62f71ba0e4dde627cd3d97ee9a28a3682e8ab2f3bedd0e75e2bb9800915d9430f9504f09ead4492d3583553db2a
+DIST bcftools-1.21.tar.bz2 7982173 BLAKE2B 7da808d1b06d2cdc0ed9ae2768a71f9e3e1de07f6e9c74504eb6f19b06481e509630e14f209ec0250c0689bf9d5807936288ba48f17830a2b004b7cfa3c23c59 SHA512 f8fb2e50a1a9e7a7e8a4f71d71d052f6019d54c60ae060d0abfbd01ab61a2c44e04e069c479ea9f6156513b54a611a9a46930a0ff4454019bb715fdb9558d07d
EBUILD bcftools-1.19.ebuild 901 BLAKE2B 401502d51a1b537d791355000f38403239ca57b41473cb58e1dcd3ab4057582fb19bec5d493df318386fe7c45337046e813a148d44ea0dda49468662d0567570 SHA512 b97efeaccdf86b37e714ff3f0e260f12927fa32eda3376b981d10ce7527b4da8f479e6b049386582e843329fa8e3d5a15236724e5a137d44219d1ebceca38097
EBUILD bcftools-1.20.ebuild 901 BLAKE2B 401502d51a1b537d791355000f38403239ca57b41473cb58e1dcd3ab4057582fb19bec5d493df318386fe7c45337046e813a148d44ea0dda49468662d0567570 SHA512 b97efeaccdf86b37e714ff3f0e260f12927fa32eda3376b981d10ce7527b4da8f479e6b049386582e843329fa8e3d5a15236724e5a137d44219d1ebceca38097
+EBUILD bcftools-1.21.ebuild 901 BLAKE2B f5dfe700dbcc84aa8d9e6cdd4fdc3e0e88a06f1f09386292c11bd0f30584c9f9114ab1340dc89a16902dcf4ff8db5f9f39523d8b9935065ad535223668835d3e SHA512 6bd99bf7f791c5fe64563481603ae15fad38871e486f394b2d2ba82a167a8e2b086f7da81ee3a9b8fb3dffe6687b9113289c3a82dadf7865a224e9397636b110
MISC metadata.xml 344 BLAKE2B 37f8e82e8a5a9ad572580a7e5ae6daa6911d672f17b8526f81b236cbc2e50a32c4cd2566aaed9f5feee016d7e2de7db2a40b60616e86c3e8cae307d60cebc70e SHA512 0160c9606089d610613d71dc0aa9c9c5e5266483fdc9c407b6e0ed911eac8f8b32ffaf5a49bbb427393c8240e9868df51f0fc68b2f45467f65d9b3d54b0ddde1
diff --git a/sci-biology/bcftools/bcftools-1.21.ebuild b/sci-biology/bcftools/bcftools-1.21.ebuild
new file mode 100644
index 000000000000..9fd45ae9ecfe
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.21.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ $(python_gen_cond_dep 'dev-python/matplotlib[${PYTHON_USEDEP}]')
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/{gff2gff,guess-ploidy,plot-roh}.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --with-htslib=system
+}
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
index 5c166b78848f..ffaea98560f6 100644
--- a/sci-biology/pysam/Manifest
+++ b/sci-biology/pysam/Manifest
@@ -1,4 +1,6 @@
DIST pysam-0.22.1.gh.tar.gz 3885851 BLAKE2B 6f83c445c7e63e28823f443b0f106726303b0609f4040e9dca930c820d48c2adfe13d33ecffb514ce75c3b03968af050652689a0be39aaabca1af546e9188480 SHA512 fb8dc7c4a6ae908d8d409789f2706cce589d4b6a1057bcc4043f8a26a5b390f79d30d1a1cbe69cbf370caabf261ed8367685393240765080e94f1782ed7f0350
+DIST pysam-0.23.0.gh.tar.gz 4076476 BLAKE2B 74f5fd99aff357c59aa4cd13214fbb87577d213461feff2afd59679c6b442ccee1fe23a7b7d6ddc723f57f4e00516fb7b67207e8f8619b707d1f909c62663006 SHA512 7c7b3806dbf316f7d9283dbabcd86e55d5dd18a01a127af5f26279e2266fb9b6e44546de0d22c82de963eca19c9e9b3ed1cc00c465acc2ddd810824902c87add
EBUILD pysam-0.22.1.ebuild 1648 BLAKE2B 9d0c666e39b48dea088445a0959d364892f9b2a3e90664788f214ac66df709c70eaaf8c90240488a4c948409f0548641f4d511af983037b3afc481444621f7fb SHA512 e35adedadd3c3726eb817c85f225fc2715eccdcd0c2bed5c11f749d07a7e99b2f28fee0244bd64f1383329d20edb7a2364112483af8a814b447b29fc3d1b762b
-EBUILD pysam-9999.ebuild 1709 BLAKE2B b7297d21abf0e581c5c2d8a72a7e6805cb5f96f6e878cc979fc0f5a34e57bdd25a2f50abaa9ee10040559e66ee42d3a24696a7093103658175b27858acaac95c SHA512 7e7a782243897a89a3539b3eb79ccd0790c6b0afcf79453526c30371f867faaf8eca6454e64d3bea250ff13753ff400fe5ff3352c080c85285cafa2346e3564a
+EBUILD pysam-0.23.0.ebuild 1502 BLAKE2B 2c9d24996e912dfa7b89b71fe03471f7e121edd897e55dd5510e75225935ba6e14502e254cbbcab3fbf0fb54964fc72949b1668ae73817641b460ca45ee9c934 SHA512 cd033f4b81ac6330af3558ec9048cac33982afc45e076354c3fa43cae36d39204f632582a02b99da7efe70a747d4b6c702b1ffab6d3a986564bffea8f26232e9
+EBUILD pysam-9999.ebuild 1619 BLAKE2B b27488491b0c85ec53dbb48cef114b7ef27b730f1faa40d4ebe070b38010e2b835140dedece889f3c0c48454c0e5c44e6a5633122e7059c403e9c6ba53f989ab SHA512 a898f0665b50ae5342964e127ea684ebc20a33d9d7ebf9b7e7712f9bc6d434500da29af800451055d3f065cf3446813d7ddb75ce02a7baf3bce004ff1d223c42
MISC metadata.xml 442 BLAKE2B e3d339868a09d8930ff6d83f414f8166ed283a66d83d5b0fed0031024db151b17b1347f5e015f2b9c2152a041e2beb70696362be9b4e3fc225078bc5c520ad58 SHA512 4b1d08c5524e1bb04129e0d38f0584654b34979024afd2cf15bd482654ca8fac9c82e6db0661f7370f9fefa6949f1291ba3c18a9dca5d5041bd6f76554fa33c7
diff --git a/sci-biology/pysam/pysam-0.23.0.ebuild b/sci-biology/pysam/pysam-0.23.0.ebuild
new file mode 100644
index 000000000000..cac7c9b72ffc
--- /dev/null
+++ b/sci-biology/pysam/pysam-0.23.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="
+ https://github.com/pysam-developers/pysam
+ https://pypi.org/project/pysam/"
+SRC_URI="https://github.com/pysam-developers/pysam/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sci-libs/htslib-1.21*:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ =sci-biology/bcftools-1.21*
+ =sci-biology/samtools-1.21*
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # only work with bundled htslib
+ 'tests/tabix_test.py::TestRemoteFileHTTP'
+ 'tests/tabix_test.py::TestRemoteFileHTTPWithHeader'
+
+ 'tests/AlignedSegment_test.py::TestBaseModifications'
+)
+
+python_prepare_all() {
+
+ # unbundle htslib
+ export HTSLIB_MODE="external"
+ export HTSLIB_INCLUDE_DIR="${ESYSROOT}"/usr/include
+ export HTSLIB_LIBRARY_DIR="${ESYSROOT}"/usr/$(get_libdir)
+ rm -r htslib || die
+
+ if use test; then
+ einfo "Building test data"
+ emake -C tests/pysam_data
+ emake -C tests/cbcf_data
+ fi
+
+ # breaks with parallel build
+ # need to avoid dropping .so plugins into
+ # build-lib, which breaks tests
+ DISTUTILS_ARGS=(
+ build_ext
+ --inplace
+ -j1
+ )
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ rm -rf pysam || die
+ epytest
+}
diff --git a/sci-biology/pysam/pysam-9999.ebuild b/sci-biology/pysam/pysam-9999.ebuild
index a162ddf2158b..d4bf32a59aab 100644
--- a/sci-biology/pysam/pysam-9999.ebuild
+++ b/sci-biology/pysam/pysam-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -23,24 +24,23 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-RDEPEND=">=sci-libs/htslib-1.17"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=sci-libs/htslib-1.21"
+DEPEND="${RDEPEND}"
BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
test? (
- >=sci-biology/bcftools-1.17
- >=sci-biology/samtools-1.17
+ >=sci-biology/bcftools-1.21
+ >=sci-biology/samtools-1.21
)"
distutils_enable_tests pytest
-DISTUTILS_IN_SOURCE_BUILD=1
-
EPYTEST_DESELECT=(
# only work with bundled htslib
'tests/tabix_test.py::TestRemoteFileHTTP'
'tests/tabix_test.py::TestRemoteFileHTTPWithHeader'
+
+ 'tests/AlignedSegment_test.py::TestBaseModifications'
)
python_prepare_all() {
@@ -50,23 +50,24 @@ python_prepare_all() {
export HTSLIB_LIBRARY_DIR="${ESYSROOT}"/usr/$(get_libdir)
rm -r htslib || die
- # prevent setup.py from adding RPATHs (except $ORIGIN)
- sed -e '/runtime_library_dirs=htslib_library_dirs/d' \
- -i setup.py || die
-
if use test; then
einfo "Building test data"
emake -C tests/pysam_data
emake -C tests/cbcf_data
fi
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
# breaks with parallel build
# need to avoid dropping .so plugins into
# build-lib, which breaks tests
- esetup.py build_ext --inplace -j1
- distutils-r1_python_compile -j1
+ DISTUTILS_ARGS=(
+ build_ext
+ --inplace
+ -j1
+ )
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ rm -rf pysam || die
+ epytest
}
diff --git a/sci-biology/samtools/Manifest b/sci-biology/samtools/Manifest
index 67b2c2142193..5f368d101179 100644
--- a/sci-biology/samtools/Manifest
+++ b/sci-biology/samtools/Manifest
@@ -1,5 +1,7 @@
DIST samtools-1.19.2.tar.bz2 9150483 BLAKE2B fb845b2ccd61f1731ef4cdc180f4b9a4ac75e8c73c1ceaa9409b99e8052ca66b88c73fc71fd1067942aa24964f6df8dcb2d93631e5757e0cc200d7a3b9fad461 SHA512 c08d729fed21112855e0acc9cf7f29c7670d38a02ad6b0f2e9b9ef15a18f07e3e194cc4f6913481c98cd3e85dd4dc975dac96155b892da58bbe8ea3679a5270f
DIST samtools-1.20.tar.bz2 9179938 BLAKE2B b534e659899a822e191c779a6ce9247854036da3435a0b63748783edc96d610ff0f02f73bbb5c1eab3ff86dbcca331113f3312a7c3376141ef89b6a8684446e4 SHA512 8526286243d057758cb846311d0a8c728026d31438e87fcc03e0df576f33bcc6da0e18bce141dbdc438a116341c94aa92701cdf10ba6b1301eadedbb34120822
+DIST samtools-1.21.tar.bz2 9149284 BLAKE2B f4e0b155b0bc8aaea81835e751d94c121f6256340e2db3a809d1ee46bed16168a0fb43d9359bf4c3967d0b77ab1151e105107c47eb0481a2c49414ffd5f1faa2 SHA512 4f80a4333ebb4dc0eb5f38f29474424b1acca9b677aa206b111c7a638b8ae924ab2dcdc9de15eb1b849576d0158579a476a7b78ccd73e7d2baafc3bbb88c6103
EBUILD samtools-1.19.2.ebuild 926 BLAKE2B a9acf64c51c87cf5d913982d22dba55901111ed1802f5795b0a1bd66979b600d815ee37c29aae83bc2d58c73a61330a4ada70fac4192022d23add1bdc89cf26c SHA512 ab73ecba708535299d9cbfc3c02a6efb292b9c85658247a7eba37b915776493027a2ca98de2e8bfe373a667119a06629a3a86f97eded244b7722887c685710c2
EBUILD samtools-1.20.ebuild 926 BLAKE2B a9acf64c51c87cf5d913982d22dba55901111ed1802f5795b0a1bd66979b600d815ee37c29aae83bc2d58c73a61330a4ada70fac4192022d23add1bdc89cf26c SHA512 ab73ecba708535299d9cbfc3c02a6efb292b9c85658247a7eba37b915776493027a2ca98de2e8bfe373a667119a06629a3a86f97eded244b7722887c685710c2
+EBUILD samtools-1.21.ebuild 926 BLAKE2B fd7c3e6acb573c32f83aa0f1f790b2c49090a10dcd92578b7a14de1e3a296fb7e916e0df35c24b79ce61f906826352a8b7281f9dd1f6ca7ed639d8357b616499 SHA512 dc6f887c62984747b496d95a987b93bc58f751036a17ed23f6c509f1e3a526afff4e2fa81f66c38b0861e782a257b6d9a623b385240ae6994ba2618b519a6365
MISC metadata.xml 409 BLAKE2B c94eab9ebda4844beb471694106e353ccbbaca53e69de680301c6cfab3f3b6224ec94fcd631c9de2811d309463e5ee6decf2e443bfc68921f3362c6a312cd3af SHA512 fb2d3686e1ee70e4e80266a26603b3e52b680b1537a4569493a3a0511b93e2acdb2be3136df7ae54905a9f86fb7e53fa054607262751ebd8f54903f1905dad24
diff --git a/sci-biology/samtools/samtools-1.21.ebuild b/sci-biology/samtools/samtools-1.21.ebuild
new file mode 100644
index 000000000000..5401fe05cd86
--- /dev/null
+++ b/sci-biology/samtools/samtools-1.21.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-htslib=system \
+ CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw || die)"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}