summaryrefslogtreecommitdiff
path: root/sci-chemistry/ParmEd
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/ParmEd')
-rw-r--r--sci-chemistry/ParmEd/Manifest2
-rw-r--r--sci-chemistry/ParmEd/ParmEd-3.0.3.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-chemistry/ParmEd/Manifest b/sci-chemistry/ParmEd/Manifest
index b778b1dfe512..63e7763ea1fa 100644
--- a/sci-chemistry/ParmEd/Manifest
+++ b/sci-chemistry/ParmEd/Manifest
@@ -1,3 +1,5 @@
DIST ParmEd-2.7.3.tar.gz 34494858 BLAKE2B 8e3ac8776f30ac73b06fd2241e5d73ba54517805ffcef7cb2f71281248df4f8afdaa05c2186ff50ba0df45df313ebdecd69a4482c8339d41baf804c37069affe SHA512 a3444f915e188bcc924f28b6b4235246e2c063ae98881c48f6e13ebc685d085d6a1bcb61b29509a343cbe58369bc6233acc20ee620c6f1d42da2033772a12e07
+DIST ParmEd-3.0.3.tar.gz 35159355 BLAKE2B 76b4655905276fe498f38c6a3bd483e89e95d3a339fbcd9ceb90d16f68d417b62e0aacaf18143d0b57167ee7acdc726c44324c844462af4d2385872210daef2a SHA512 60b8ee100a301fbddec8323a3dba550c96ffa09624f41e457d4b3941a4e4a15e903c3da6de24a5183731406f19f9e6436a2111d654bc902c0f06ac8b643acf09
EBUILD ParmEd-2.7.3.ebuild 834 BLAKE2B 6e4210b0f874f70b384373cfe13f56998850f9fad7eeafb4854054f847286e6b72da412328616245ba8df48cfb50d61c7c78c2f548e278ab3b1414859cd178c5 SHA512 af1046b0ea4ad34a6ec3871da13fb42b1290654d26278c77dc4a2d27bde941f4782acc0da7bf6c3b9fcb0599596938e1bce60572a7768bdef2cf516f888c6df3
+EBUILD ParmEd-3.0.3.ebuild 835 BLAKE2B 5ea026dffca8d6c7fca6514f8b0b0904d932125e980a9629b994cddcab47fb8d84886bebbef9748315c741bad2850db1e836d455343a8b643b50c5a98776cc0e SHA512 960747822dd07c0e24391f7bb3447e7518772af852ee7406f2fa80603a789293051ba2f0230504fdabf8c1a9afa3c88db262aa8749af92d05647d86b0832511a
MISC metadata.xml 468 BLAKE2B 2e3781c6ebea297fb8480c2d54be22da0e8d6906607513e3b78fe89a926cf691048fb90576cadde7321d964e8269950437f48bb54270c9a1bd487bfe3ce30b84 SHA512 47e3516aabe02112a52e851ac9294a0096001373d546462f9185754356c72dd37a0a8efa3b40311e43e27e2953ea5879c1141488649f3faef0aa43a692205499
diff --git a/sci-chemistry/ParmEd/ParmEd-3.0.3.ebuild b/sci-chemistry/ParmEd/ParmEd-3.0.3.ebuild
new file mode 100644
index 000000000000..6ea7bdee606e
--- /dev/null
+++ b/sci-chemistry/ParmEd/ParmEd-3.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Parameter/topology editor and molecular simulator"
+HOMEPAGE="https://parmed.github.io/ParmEd/html/index.html"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed \
+ -e "/delfile/d" \
+ -e "/deldir/d" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}