summaryrefslogtreecommitdiff
path: root/sci-chemistry/bkchem
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/bkchem')
-rw-r--r--sci-chemistry/bkchem/Manifest6
-rw-r--r--sci-chemistry/bkchem/bkchem-0.14.0_pre2-r1.ebuild40
-rw-r--r--sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch106
-rw-r--r--sci-chemistry/bkchem/metadata.xml8
4 files changed, 160 insertions, 0 deletions
diff --git a/sci-chemistry/bkchem/Manifest b/sci-chemistry/bkchem/Manifest
new file mode 100644
index 000000000000..6d2432b89d1d
--- /dev/null
+++ b/sci-chemistry/bkchem/Manifest
@@ -0,0 +1,6 @@
+AUX bkchem-0.14.0_pre2-nolauncher.patch 2967 SHA256 91f95fedb29a3d6be3581a2aa056dc961176af0296d2fdbd1c0d0ba28e321312 SHA512 dbd7b8eef583c3b64dfc1755a3b5eae5eb8ab222454936636147de64e021166e29f915655f1acf2d7252983bf4873dc8f2fb69ca58b56955ab1ce07e8ec82789 WHIRLPOOL 2f4c410a30d08d7d7bb472a97afaa5969046e164098b1a9bd6cca03de0dd622e9ee9c150f2cc3b05cff4e4a2d9a63d6bb9b1f5503d012f7b4172ee2da708b35a
+DIST bkchem-0.14.0-pre2.tar.gz 998916 SHA256 65b93128932959b394eff8e5a8018a19b30d26ee1ae44345e8bb87167303ed26 SHA512 7fc3bbd7bfe27bc91cf69a98c347a3fb92f4ea25b45a13debd0646a6b02d7a40c5729ae1b2a9ac33c1049d6b90e38355c3cd80e06660a0a2fcc5dafb3514ef20 WHIRLPOOL 732bc45913248aa3df5929933f2072d09d90a46cdc3b3e22f1849adf391d7fd62704e71a98e24649bd74e1ebe96b30d7d398dadabffc0fcd114d8c13922241c6
+EBUILD bkchem-0.14.0_pre2-r1.ebuild 892 SHA256 9de4a30312a4b763f3508bbd6bfbeb4d374f5873f0ea15a2a955fa3483b8162e SHA512 32b82b62e7b190595a2a28cd2e7ae76d55d9cddd13646a01d472808eb75d6edd89dc3828794f8c070199b6d77461d4e4911bda69aea3ff03339219ba3313962b WHIRLPOOL be05f521c005505b50d404206f2daf041170d66d41ffc6c2c4d1e72f7018fec22a51601b3c2fc109bef1d53d82977272c606ecc716795ec54059d59bd1aab948
+MISC ChangeLog 2683 SHA256 c71c3912adfe474ef74a6e517e9000c224df212712260ff8c5f844e23dc08161 SHA512 ee9900aa765475b17b8e77f0b987fa497ebc7c4f78b082588edd6191fd3b63d2ef846da6a73f7881db0b1696a5bef5f5c0b4564b2b3e8ceb283b72f0ff01d34f WHIRLPOOL dda78e54e38bde0eb86de2d432313e26493c1ffadce523a4a01da52b306e1ac13d8c61e293ec9324e0593b14dc9ff48356356ed810b2f44fc9a0d5095c8f8f1a
+MISC ChangeLog-2015 1485 SHA256 900b36366bc55b134110ccee4b046df0cfb9e12175b8f4f50a22eb42964d82a9 SHA512 ff44c6d6b8702cab41b44ad5300aa199fe9c7a383372fa28c44f0ee2e6949e8867e1263f98696afe504a925df700c9d72a571ce0a1d893eab72b836469398261 WHIRLPOOL a53a5e234f143cccd36493f881e94f4ed27f09a7e2883a2c4029c3c0077778539389591c3c4718627698a1bfaabd5ef4e02b9d338ff3db7e0377fdf6cbaab1da
+MISC metadata.xml 271 SHA256 70036ea85140f86ed670bc2791c9de861c4b6164755ee36a2560d1c812ec13f6 SHA512 3e6e6047a29e07123b81279cae1de17bc4bd4c3d7d8a8d26560114a18185f473d038fc220fa81c7213fa203ce197bad8b1c272d9b7e41cd770a953fa6308ff92 WHIRLPOOL 1ccb964819c99258af550a41c6712ba8ebdecbec1c821106de2f22c37b1c981cd4f324856a8014b08bd186bcd2a7fa45a7e772cc15705d1a39016b5229e77269
diff --git a/sci-chemistry/bkchem/bkchem-0.14.0_pre2-r1.ebuild b/sci-chemistry/bkchem/bkchem-0.14.0_pre2-r1.ebuild
new file mode 100644
index 000000000000..35fa24221e61
--- /dev/null
+++ b/sci-chemistry/bkchem/bkchem-0.14.0_pre2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 eutils versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="Chemical drawing program"
+HOMEPAGE="http://bkchem.zirael.org/"
+SRC_URI="http://bkchem.zirael.org/download/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+IUSE="cairo"
+
+DEPEND="cairo? ( dev-python/pycairo[svg,${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-nolauncher.patch
+)
+
+python_install() {
+ distutils-r1_python_install "--strip=${ED}/_${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ python_foreach_impl python_newscript ${PN}/${PN}.py ${PN}
+ make_desktop_entry bkchem BKChem "${EPREFIX}"/usr/share/${PN}/images/${PN}.png Science
+}
diff --git a/sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch b/sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch
new file mode 100644
index 000000000000..202c47a9c74f
--- /dev/null
+++ b/sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch
@@ -0,0 +1,106 @@
+ bkchem/bkchem.py | 24 +++++++++++++-----------
+ setup.py | 23 -----------------------
+ 2 files changed, 13 insertions(+), 34 deletions(-)
+
+diff --git a/bkchem/bkchem.py b/bkchem/bkchem.py
+index b336b9c..bcb68b0 100644
+--- a/bkchem/bkchem.py
++++ b/bkchem/bkchem.py
+@@ -1,3 +1,4 @@
++#!/usr/bin/env python2
+ #--------------------------------------------------------------------------
+ # This file is part of BKChem - a chemical drawing program
+ # Copyright (C) 2002-2009 Beda Kosata <beda@zirael.org>
+@@ -18,18 +19,19 @@
+ #--------------------------------------------------------------------------
+
+
+-"""this is just a starter of the application"""
++#"""this is just a starter of the application"""
+
+ ## support for loading from outside of bkchem dir
+
+-import os_support, sys
++from bkchem import os_support
++import sys
+ sys.path.insert( 1, os_support.get_module_path())
+
+
+ ### now starting for real
+
+-from singleton_store import Store
+-import pref_manager
++from bkchem.singleton_store import Store
++from bkchem import pref_manager
+
+ # at first preference manager
+ Store.pm = pref_manager.pref_manager(
+@@ -78,13 +80,13 @@ else:
+
+
+
+-import config
++from bkchem import config
+
+ if not config.debug:
+ # checking of important modules availability
+ # import modules
+- import import_checker
+- import messages
++ from bkchem import import_checker
++ from bkchem import messages
+
+ # we need sets from the 2.3 version
+ if not import_checker.python_version_ok:
+@@ -103,16 +105,16 @@ if not config.debug:
+
+
+ #import Tkinter
+-from main import BKChem
+-from splash import Splash
+-from singleton_store import Store
++from bkchem.main import BKChem
++from bkchem.splash import Splash
++from bkchem.singleton_store import Store
+
+ myapp = BKChem()
+ myapp.withdraw()
+
+ if __name__ == '__main__':
+
+- import messages
++ from bkchem import messages
+ enc = sys.getfilesystemencoding()
+ if not enc:
+ enc = sys.getdefaultencoding()
+diff --git a/setup.py b/setup.py
+index d4b2a21..2319216 100755
+--- a/setup.py
++++ b/setup.py
+@@ -91,26 +91,3 @@ if len( sys.argv) > 1 and sys.argv[1] == 'install' and '--help' not in sys.argv:
+ print "file %s created" % config_name
+
+
+- # the executable
+- if not os.path.isdir( bin_dir):
+- try:
+- os.mkdir( bin_dir)
+- except:
+- print "ERROR: could not create directory %s" % bin_dir
+- sys.exit( 201)
+- exec_name = os.path.join( bin_dir, 'bkchem')
+- try:
+- file = open( exec_name, 'w')
+- except:
+- print "ERROR: couldn't open the file %s for write" % exec_name
+- sys.exit( 201)
+- file.write( "#!/bin/sh\n")
+- file.write( 'python %s "$@"\n' % strip_path( os.path.join( py_dir, "bkchem", "bkchem.py")))
+- file.close()
+- print "file %s created" % exec_name
+- try:
+- os.chmod( os.path.join( bin_dir, 'bkchem'), 5+5*8+7*8*8)
+- except:
+- print "ERROR: failed to make %s executable" % exec_name
+- sys.exit( 201)
+- print "file %s made executable" % exec_name
diff --git a/sci-chemistry/bkchem/metadata.xml b/sci-chemistry/bkchem/metadata.xml
new file mode 100644
index 000000000000..8937bad0b175
--- /dev/null
+++ b/sci-chemistry/bkchem/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+</pkgmetadata>