summaryrefslogtreecommitdiff
path: root/sci-chemistry/mongochem/mongochem-0.7.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mongochem/mongochem-0.7.0-r1.ebuild')
-rw-r--r--sci-chemistry/mongochem/mongochem-0.7.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-chemistry/mongochem/mongochem-0.7.0-r1.ebuild b/sci-chemistry/mongochem/mongochem-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..ad698d3c74d7
--- /dev/null
+++ b/sci-chemistry/mongochem/mongochem-0.7.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils vcs-snapshot
+
+DESCRIPTION="Application for managing large collections of chemical data"
+HOMEPAGE="http://www.openchemistry.org/"
+#SRC_URI="http://openchemistry.org/files/v0.5/${P}.tar.gz"
+SRC_URI="https://github.com/OpenChemistry/mongochem/archive/df36ebce92024dd4fd1c70eb37eb84e4c51120ff.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost[threads]
+ dev-libs/mongo-cxx-driver
+ sci-libs/avogadrolibs[qt4]
+ sci-libs/chemkit
+ sci-libs/vtk[qt4,rendering]
+ sci-chemistry/molequeue
+"
+DEPEND="${RDEPEND}"