summaryrefslogtreecommitdiff
path: root/sci-electronics/qelectrotech/qelectrotech-0.61.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/qelectrotech/qelectrotech-0.61.ebuild')
-rw-r--r--sci-electronics/qelectrotech/qelectrotech-0.61.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/sci-electronics/qelectrotech/qelectrotech-0.61.ebuild b/sci-electronics/qelectrotech/qelectrotech-0.61.ebuild
deleted file mode 100644
index 38d8540b0f54..000000000000
--- a/sci-electronics/qelectrotech/qelectrotech-0.61.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P=${PN}-${PV%0}-src
-inherit qmake-utils xdg-utils
-
-DESCRIPTION="Qt5 application to design electric diagrams"
-HOMEPAGE="https://qelectrotech.org/"
-SRC_URI="https://download.tuxfamily.org/qet/tags/20180823/${MY_P}.tar.gz"
-
-LICENSE="CC-BY-3.0 GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-BDEPEND="
- doc? ( app-doc/doxygen )
-"
-RDEPEND="
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtprintsupport:5
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
-"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( CREDIT ChangeLog README )
-
-PATCHES=( "${FILESDIR}/${PN}-0.3-fix-paths.patch" )
-
-src_configure() {
- eqmake5 ${PN}.pro
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
-
- if use doc; then
- doxygen Doxyfile || die
- local HTML_DOCS=( doc/html/. )
- fi
-
- einstalldocs
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}