summaryrefslogtreecommitdiff
path: root/sci-electronics
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/Manifest.gzbin8561 -> 8556 bytes
-rw-r--r--sci-electronics/spice/Manifest3
-rw-r--r--sci-electronics/spice/files/spice-3.5.5-makefile-exit-on-fail.patch66
-rw-r--r--sci-electronics/spice/spice-3.5.5-r4.ebuild10
4 files changed, 77 insertions, 2 deletions
diff --git a/sci-electronics/Manifest.gz b/sci-electronics/Manifest.gz
index 666049016457..058be8c2081c 100644
--- a/sci-electronics/Manifest.gz
+++ b/sci-electronics/Manifest.gz
Binary files differ
diff --git a/sci-electronics/spice/Manifest b/sci-electronics/spice/Manifest
index 6cf425e4c27c..cece1243ecaa 100644
--- a/sci-electronics/spice/Manifest
+++ b/sci-electronics/spice/Manifest
@@ -1,5 +1,6 @@
AUX spice-3.5.5-arlocal.patch 453 BLAKE2B 63d03a34041e5c53fb93b21a57bd4ef5a4323b1adf248970e04843da294c8c05d83e1dbd25255214902f2c569c53416eebe5beb3f797e90f2aeb56a16690d1d7 SHA512 30ab32d6b89087ac02a2d2a2a13974f3d6da4fbf41979e357b794d46d3bf696b0216839f9570eee67d746663101b4aebbc1ae3e83c7f1b79c22ac5e7d3997206
AUX spice-3.5.5-gcc-4.1.patch 2511 BLAKE2B d9bb215dfcaf595d9f62a4748507342c3b6242f551a8458965e37c13e34432d686f00b91ee27d80451261b8baa9d0bd9616b378b246fc895b0dc1fff0d4975c8 SHA512 9ae98c77d8a95b2ccac03e48d778b431a449f8383938ca2d71dc1d77254a0dade6c159f1723aa9a00ac921379ec210584c32ae7e63a849bd07691d34bd92d5c7
+AUX spice-3.5.5-makefile-exit-on-fail.patch 2430 BLAKE2B efa9445c311c2a6c1deab4bac5d8a1d2a5a1219b8b9bc2e522240fd4e055feed3df82f462c2c1040beffc8b6d7cff7aab9c7ef5200f3925a96645a9e7565e0c9 SHA512 924fe8ca7bc72b8c5496603e0d3479736e2b5575b6c764802faa1457be1cd1aa6877e3538535130a3652167193ec4d369d18cafa2fec5fe98a01acc0dc09244b
DIST spice3f5sfix.tar.gz 1377263 BLAKE2B bffc4ae307c8b02db998e412d09ae52cef1aea78ab28d0c0b040f2c253032d0f42978c2d3b0bb0500e78016a35e2064bd50d6f86abdeb1e885bc7f7f0978864c SHA512 a515dbfcf81b302667e4a39b0ee7f02715c2a6a3fb9b3d320d9a4bea81e557c85f14d1e9d01d598d8ad3a6a67a797c2096bc14acc8e5afb41bef51f56b400be8
-EBUILD spice-3.5.5-r4.ebuild 2020 BLAKE2B 3922f3c78fa35dc77c17addf381940f701bbece8bdaa8ddaf5bff895deb072e53926880c1855ba64587aafcce5c628d880be37e0826902b32a6249d3c298088c SHA512 e668013d39204814505efd17f469093a402f6bb6897ea6c586f37118627edfaae1948f71645c286c07a7f0d99ee84bc645ff528c56ef4181ef56dd264f26926b
+EBUILD spice-3.5.5-r4.ebuild 2345 BLAKE2B 30f4b1cd62153153f6eac36e3d067fc2f82c8dca2cb2ffb66628b61e00610f170803724276ed7f38cde2944eca1932c63b40cdd0a726a2c0e8d458aa9a9b5184 SHA512 072da5ac711344acbcb0c31a118d270bce10606af718f187c18aba11e1b9b2e08f608a464cf8a71477865fc9bfa9bd10bd48ad43db8a0382789c29ab198a1bc4
MISC metadata.xml 796 BLAKE2B 895d71188de1aa825622a54bc39894209e783a14bb7d611d08f54800c02cf42869d10e56827c864ebdd77599b1700a3814e72f24dd25beb162b8cff677f7699d SHA512 0c661364645513cc53a25ff0d292b86254c1dce6cf0336210980dea9c47f8ac5113b4760a61237da27a4f167c822452e3a227ef3a9023b33604732fe3acb7eae
diff --git a/sci-electronics/spice/files/spice-3.5.5-makefile-exit-on-fail.patch b/sci-electronics/spice/files/spice-3.5.5-makefile-exit-on-fail.patch
new file mode 100644
index 000000000000..f0af690c9fef
--- /dev/null
+++ b/sci-electronics/spice/files/spice-3.5.5-makefile-exit-on-fail.patch
@@ -0,0 +1,66 @@
+From 57beed0c071b159695a8695de23325bdfd5f1ec6 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Thu, 3 Apr 2025 20:51:10 -0400
+Subject: [PATCH] src_compile: exit on failure
+
+This "build script" wraps around `make` in some horrifying ways. And as
+a result, if make exits with an error this is ignored.
+
+To cap it off, the entire software is based around recursive make -k so
+it takes forever to build and return errors. There is no point in doing
+this just to get a failed build; be more responsive.
+---
+ util/build | 2 +-
+ util/skeleton/make_std.bd | 8 ++++----
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/util/build b/util/build
+index bf4bbcc..c740858 100755
+--- a/util/build
++++ b/util/build
+@@ -172,7 +172,7 @@ if test -z "${DEBUG}"; then
+ $EXEC cat ${FILES0} "${TOP0}/${DIR}/${SUBDIR}/makedefs" \
+ "${TMP_TRAILER}" "${SKEL_DIR}/make_std.bd" \
+ | make -f - bootstrap DIR="${DIR}" SUBDIR="${SUBDIR}" \
+- VPATH="${TOP0}/${DIR}/${SUBDIR}" CWD="${CWD}"
++ VPATH="${TOP0}/${DIR}/${SUBDIR}" CWD="${CWD}" || exit
+ echo Done with build at `date`
+ else
+ $EXEC cat ${FILES0} "${TOP0}/${DIR}/${SUBDIR}/makedefs" \
+diff --git a/util/skeleton/make_std.bd b/util/skeleton/make_std.bd
+index d4ef591..50baf3a 100644
+--- a/util/skeleton/make_std.bd
++++ b/util/skeleton/make_std.bd
+@@ -16,17 +16,17 @@ BUILD_DIR = \
+ echo Making \"$(PURPOSE)\" in "$${NEW_NAME}"; \
+ cat $(FILES_L) $${NEW_DIR}/makedefs \
+ $(FILES_T) $${OFILE} $${DFILE} \
+- | ${MAKE} -f - -k recursive \
++ | ${MAKE} -f - recursive \
+ PARENT="$${NEW_PARENT}" NAME="$${NEW_NAME}" \
+ $${SET_COMP} $${COMP_TO_CWD} $${CWD_TO_COMP} \
+ VPATH="$${NEW_VPATH}" SUBDIR="$${SUBDIR}" \
+- DIR="$${DIR}"
++ DIR="$${DIR}" || exit
+
+ .c.o:
+ $(CC) $(CFLAGS) $(INCLUDE) -c $(SRC_DIR)/$*.c $(OUTPUT) $(ASM_HACK)
+
+ bootstrap: always
+- -@if test "x$(DIR)" = "xsrc/"; then \
++ @if test "x$(DIR)" = "xsrc/"; then \
+ if test ! -d "$(OBJ_DIR)"; then \
+ $(MKDIR) -p "$(OBJ_DIR)"; \
+ fi; \
+@@ -41,7 +41,7 @@ bootstrap: always
+ $(BUILD_DIR);
+
+ recurse: $(PRE_PURPOSE) $(UPDATE_TARGET)
+- -@SUBDIRS="$(MAKE_SUBDIRS)"; \
++ @SUBDIRS="$(MAKE_SUBDIRS)"; \
+ for xx in $${SUBDIRS}; do \
+ if test -z "$(DIR)"; then \
+ DIR=$${xx}/; \
+--
+2.49.0
+
diff --git a/sci-electronics/spice/spice-3.5.5-r4.ebuild b/sci-electronics/spice/spice-3.5.5-r4.ebuild
index 383863ebe1d0..07d33da42157 100644
--- a/sci-electronics/spice/spice-3.5.5-r4.ebuild
+++ b/sci-electronics/spice/spice-3.5.5-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -33,15 +33,23 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc-4.1.patch
# Bug https://bugs.gentoo.org/783192
"${FILESDIR}"/${P}-arlocal.patch
+ # util/build never exits on failure, leading to confusing reports
+ "${FILESDIR}"/${P}-makefile-exit-on-fail.patch
)
src_prepare() {
# spice accepts -O1 at most
replace-flags -O* -O1
+ # The code is from 1989, later updated in 1993. It is deeply incompatible
+ # with Modern C (c99). It also needs `#define linux` from gnu...
+ append-flags -std=gnu89
+
# Avoid re-creating WORKDIR due to stupid mtime
touch ..
+ echo "CC = $(tc-getCC)" >> conf/defaults
+
sed -i -e "s/termcap/ncurses/g" \
-e "s/joe/\/usr\/libexec\/editor/g" \
-e "s/-O2 -s/${CFLAGS}/g" \