summaryrefslogtreecommitdiff
path: root/sci-electronics
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/Manifest.gzbin8713 -> 8714 bytes
-rw-r--r--sci-electronics/librepcb/Manifest2
-rw-r--r--sci-electronics/librepcb/librepcb-1.2.0.ebuild65
3 files changed, 67 insertions, 0 deletions
diff --git a/sci-electronics/Manifest.gz b/sci-electronics/Manifest.gz
index 055ef37b9dfa..2e0ab2b2815c 100644
--- a/sci-electronics/Manifest.gz
+++ b/sci-electronics/Manifest.gz
Binary files differ
diff --git a/sci-electronics/librepcb/Manifest b/sci-electronics/librepcb/Manifest
index 4e7fc8dc993d..9f6bd1ef1d46 100644
--- a/sci-electronics/librepcb/Manifest
+++ b/sci-electronics/librepcb/Manifest
@@ -1,3 +1,5 @@
DIST librepcb-1.1.0-source.zip 15373750 BLAKE2B 6f8ba8d66b95373e4760aae617b423e71fcb89ceb39703ce4547a390e4ad0630866632d9bad01f93780fdb8c3452ec0424e753ef891402e440686c64eba56495 SHA512 2ca02095d89547e17813fcfeadedd48fb9345d177885c9d21a8d313d864c6f02243eb13a33341c474bc0671a66ef6b00b6329760aeb3439fdb10123f2db9d38b
+DIST librepcb-1.2.0-source.zip 15923398 BLAKE2B b7ec8dc5ff4b9531e4614defe8e95ec4bf3da796f5aece8d849aed6dfa3d352149fbdb928cf5b24510266977dd9648634ab89a7e675f29d990849bb314a252e8 SHA512 a7e7a0e4e433000db39501874240652d85fe3a2be08f442c72138b70ec3faa0e8117399a997f2083e31d54a5f9276c02fa5a101d3855fad8d1c5cd78f1d80a8f
EBUILD librepcb-1.1.0-r2.ebuild 1711 BLAKE2B 0cbafdad1e485e0c8aac25c686a69b9dd32da4d56408a58e5f2daf9fbb2490ed311ec9dbc95520476395447cf1fb75586c7d5868a6a14f9fa647aa3722f182ef SHA512 101e772b438317c1c95c06c802fe8c4ad9f934d1e25b915113f891f02ccf959457503fbdce4449c526df37858233602dc2884a56b4c442a03173a6f40032bc6b
+EBUILD librepcb-1.2.0.ebuild 1687 BLAKE2B 6b5259acbd9270f529536a611cea6ce2f8aef4a702264fd600e45a1c9d180cbbbd75f0afd798e7ead3d6b8935ed8ed1b38262411b49a6b31a5cea133a5140bdb SHA512 c848bef3d7c1aa8b0247e8bd9286b12aa4ecb63e6afec7989efd9094fb6941ec2fd9a7a5f4709050d36e1974068b123d4b0aec630de8d7ce4a9488427b03ef1b
MISC metadata.xml 1316 BLAKE2B 0e2933c46eed63177cc16902e0c9235cd77640af852a5b2242db98b4dda997a3d9ede5e79b95d860b162ab6055a67935c828309ea32e81e4e2551e2f37d0e3bd SHA512 e5dc0108675528726309169119d7c09fcc7da55d68981314bf61fed0a14109bf69363eabf9360164f55b6912a7d1d451aabfc21d73e209c638561a37e74fa61d
diff --git a/sci-electronics/librepcb/librepcb-1.2.0.ebuild b/sci-electronics/librepcb/librepcb-1.2.0.ebuild
new file mode 100644
index 000000000000..9ac74c9d417e
--- /dev/null
+++ b/sci-electronics/librepcb/librepcb-1.2.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2009-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Free EDA software to develop printed circuit boards"
+HOMEPAGE="https://librepcb.org/"
+SRC_URI="https://download.librepcb.org/releases/${PV}/${P}-source.zip"
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="opencascade test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-cpp/muParser:=
+ >=dev-libs/quazip-1.3-r2:=[qt6(+)]
+ dev-qt/qtbase:6[concurrent,gui,network,opengl,sql,sqlite,ssl,widgets]
+ dev-qt/qtdeclarative:6
+ dev-qt/qtsvg:6
+ media-libs/libglvnd[X]
+ sys-libs/zlib
+ virtual/glu
+ opencascade? ( sci-libs/opencascade:= )"
+
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+
+BDEPEND="
+ app-arch/unzip
+ dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_MAJOR_VERSION=6
+ -DUNBUNDLE_GTEST=ON
+ -DUNBUNDLE_MUPARSER=ON
+ -DUNBUNDLE_QUAZIP=ON
+ -DUSE_OPENCASCADE=$(usex opencascade 1 0)
+ -DBUILD_TESTS=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local -x QT_QPA_PLATFORM=offscreen
+ cd "${BUILD_DIR}"/tests/unittests || die
+ # https://github.com/LibrePCB/LibrePCB/issues/516
+ ./librepcb-unittests --gtest_filter=-SystemInfoTest.testGetUsername:CategoryTreeModelTest.testSort:BoardPlaneFragmentsBuilderTest.testFragments:BoardGerberExportTest.test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ewarn
+ ewarn "LibrePCB builds might not be exactly reproducible with e.g. -march={native,haswell,...}."
+ ewarn "This can cause minor issues, see for example:"
+ ewarn "https://github.com/LibrePCB/LibrePCB/issues/516"
+ ewarn "For a completely reproducible build use: -march=x86-64."
+ ewarn
+}