summaryrefslogtreecommitdiff
path: root/sci-libs/HighFive/HighFive-2.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/HighFive/HighFive-2.10.1.ebuild')
-rw-r--r--sci-libs/HighFive/HighFive-2.10.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sci-libs/HighFive/HighFive-2.10.1.ebuild b/sci-libs/HighFive/HighFive-2.10.1.ebuild
new file mode 100644
index 000000000000..8995434dd26f
--- /dev/null
+++ b/sci-libs/HighFive/HighFive-2.10.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="app-text/doxygen[dot]"
+DOCS_DIR="doc"
+
+inherit cmake docs
+
+DESCRIPTION="Header-only C++ interface for libhdf5"
+HOMEPAGE="https://github.com/BlueBrain/HighFive"
+SRC_URI="https://github.com/BlueBrain/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mpi test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-libs/hdf5[mpi?]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-cpp/catch-3.4.0:0
+ dev-libs/boost
+ dev-cpp/eigen
+ media-libs/opencv
+ )
+"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_configure() {
+ default
+ local mycmakeargs=(
+ -DHIGHFIVE_PARALLEL_HDF5=$(usex mpi)
+
+ -DHIGHFIVE_USE_BOOST=$(usex test)
+ -DHIGHFIVE_USE_EIGEN=$(usex test)
+ -DHIGHFIVE_USE_OPENCV=$(usex test)
+ -DHIGHFIVE_USE_XTENSOR=OFF
+
+ -DHIGHFIVE_EXAMPLES=$(usex test)
+ -DHIGHFIVE_UNIT_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ default
+ use test && cmake_src_compile
+ use doc && doxygen_compile
+}
+
+src_test() {
+ # Set -j1 to prevent race
+ cmake_src_test -j1
+}