summaryrefslogtreecommitdiff
path: root/sci-libs/Shapely/Shapely-1.5.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/Shapely/Shapely-1.5.17.ebuild')
-rw-r--r--sci-libs/Shapely/Shapely-1.5.17.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/Shapely/Shapely-1.5.17.ebuild b/sci-libs/Shapely/Shapely-1.5.17.ebuild
new file mode 100644
index 000000000000..a90108d26d17
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.5.17.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}