summaryrefslogtreecommitdiff
path: root/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild')
-rw-r--r--sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild b/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
index 30cce977960d..4bd35e1b7fc8 100644
--- a/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
+++ b/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_ECLASS=cmake
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit cmake-multilib python-any-r1 toolchain-funcs
DESCRIPTION="Nonlinear least-squares minimizer"
@@ -23,8 +23,10 @@ RESTRICT="!test? ( test )"
BDEPEND="${PYTHON_DEPS}
>=dev-cpp/eigen-3.3.4:3
doc? (
- dev-python/sphinx
- dev-python/sphinx_rtd_theme
+ $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ')
)
lapack? ( virtual/pkgconfig )
"