summaryrefslogtreecommitdiff
path: root/sci-libs/gerris/files/gerris-20131206-DEFAULT_SOURCE-replacement.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gerris/files/gerris-20131206-DEFAULT_SOURCE-replacement.patch')
-rw-r--r--sci-libs/gerris/files/gerris-20131206-DEFAULT_SOURCE-replacement.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/sci-libs/gerris/files/gerris-20131206-DEFAULT_SOURCE-replacement.patch b/sci-libs/gerris/files/gerris-20131206-DEFAULT_SOURCE-replacement.patch
new file mode 100644
index 000000000000..d20df635512c
--- /dev/null
+++ b/sci-libs/gerris/files/gerris-20131206-DEFAULT_SOURCE-replacement.patch
@@ -0,0 +1,16 @@
+Silence warnings due to _BSD_SOURCE being deprecated by glib:
+* /usr/include/features.h:148:3: warning: #warning "_BSD_SOURCE and
+* _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
+* # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -108,7 +108,7 @@
+ AC_PROG_CC
+
+ # -D_GNU_SOURCE is only necessary for old (< 2.10) glibc implementations of open_memstream()
+-CFLAGS="$CFLAGS -D_XOPEN_SOURCE=700 -D_BSD_SOURCE -D_GNU_SOURCE"
++CFLAGS="$CFLAGS -D_XOPEN_SOURCE=700 -D_DEFAULT_SOURCE -D_GNU_SOURCE"
+ if test x$GCC = xyes ; then
+ CFLAGS="$CFLAGS -Wall -Werror-implicit-function-declaration -Wmissing-prototypes -Wmissing-declarations -pipe -std=c99"
+ fi