summaryrefslogtreecommitdiff
path: root/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch')
-rw-r--r--sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch14
1 files changed, 2 insertions, 12 deletions
diff --git a/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch b/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch
index 09f7588a1858..1344d42a0c3f 100644
--- a/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch
+++ b/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch
@@ -12,7 +12,7 @@
set(GLOO_VERSION_PATCH 0)
--- a/gloo/CMakeLists.txt 2022-06-09 08:41:09.883773600 +0200
+++ b/gloo/CMakeLists.txt 2022-06-09 08:42:39.045637103 +0200
-@@ -176,7 +176,7 @@
+@@ -181,7 +181,7 @@
# want to statically link with Gloo and not install any artifacts.
if(GLOO_INSTALL)
install(TARGETS gloo EXPORT GlooTargets
@@ -23,7 +23,7 @@
DESTINATION ${CMAKE_INSTALL_PREFIX}/lib)
--- a/gloo/test/CMakeLists.txt 2022-06-10 22:17:03.682856314 +0200
+++ b/gloo/test/CMakeLists.txt 2022-06-10 22:17:49.671242697 +0200
-@@ -68,3 +68,4 @@
+@@ -73,3 +73,4 @@
gloo_hip_add_executable(gloo_test_hip ${GLOO_TEST_HIP_SRCS})
target_link_libraries(gloo_test_hip gloo_hip gtest OpenSSL::SSL OpenSSL::Crypto)
endif()
@@ -62,16 +62,6 @@
endif()
endif()
---- a/gloo/transport/tcp/device.cc 2022-08-02 11:25:32.404166606 +0200
-+++ b/gloo/transport/tcp/device.cc 2022-08-02 11:25:48.706963018 +0200
-@@ -12,6 +12,7 @@
- #include <netdb.h>
- #include <netinet/in.h>
- #include <string.h>
-+#include <array>
-
- #include "gloo/common/linux.h"
- #include "gloo/common/logging.h"
--- a/gloo/transport/tcp/tls/pair.cc 2022-10-04 21:14:04.099150060 +0200
+++ b/gloo/transport/tcp/tls/pair.cc 2022-10-04 21:14:22.330886610 +0200
@@ -17,6 +17,7 @@