summaryrefslogtreecommitdiff
path: root/sci-libs/gloo/files/gloo-2023.01.17-cuda.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gloo/files/gloo-2023.01.17-cuda.patch')
-rw-r--r--sci-libs/gloo/files/gloo-2023.01.17-cuda.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/sci-libs/gloo/files/gloo-2023.01.17-cuda.patch b/sci-libs/gloo/files/gloo-2023.01.17-cuda.patch
new file mode 100644
index 000000000000..1a894d3e4251
--- /dev/null
+++ b/sci-libs/gloo/files/gloo-2023.01.17-cuda.patch
@@ -0,0 +1,13 @@
+diff --git a/gloo/CMakeLists.txt b/gloo/CMakeLists.txt
+index 9ee82df..3b3affb 100644
+--- a/gloo/CMakeLists.txt
++++ b/gloo/CMakeLists.txt
+@@ -184,7 +184,7 @@ if(GLOO_INSTALL)
+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ if(USE_CUDA)
+ install(TARGETS gloo_cuda EXPORT GlooTargets
+- DESTINATION ${CMAKE_INSTALL_PREFIX}/lib)
++ DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ endif()
+ if(USE_ROCM)
+ install(TARGETS gloo_hip EXPORT GlooTargets