summaryrefslogtreecommitdiff
path: root/sci-libs/gloo/gloo-2022.05.18-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gloo/gloo-2022.05.18-r1.ebuild')
-rw-r--r--sci-libs/gloo/gloo-2022.05.18-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sci-libs/gloo/gloo-2022.05.18-r1.ebuild b/sci-libs/gloo/gloo-2022.05.18-r1.ebuild
deleted file mode 100644
index f22733551794..000000000000
--- a/sci-libs/gloo/gloo-2022.05.18-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit cmake
-
-CommitId=5b143513263133af2b95547e97c07cebeb72bf72
-
-DESCRIPTION="library of floating-point neural network inference operators"
-HOMEPAGE="https://github.com/facebookincubator/gloo/"
-SRC_URI="https://github.com/facebookincubator/${PN}/archive/${CommitId}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="libuv mpi redis ssl test"
-
-RDEPEND="
- libuv? ( dev-libs/libuv )
- mpi? ( virtual/mpi )
- redis? (
- dev-db/redis
- dev-libs/hiredis
- )
- ssl? ( dev-libs/openssl:0/1.1 )
-"
-DEPEND="${RDEPEND}
-"
-
-BDEPEND="test? ( dev-cpp/gtest )"
-RESTRICT="test" # For some test the network is needed
-
-S="${WORKDIR}"/${PN}-${CommitId}
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TEST=$(usex test ON OFF)
- -DUSE_LIBUV=$(usex libuv ON OFF)
- -DUSE_MPI=$(usex mpi ON OFF)
- -DUSE_REDIS=$(usex redis ON OFF)
- -DUSE_TCP_OPENSSL_LINK=$(usex ssl ON OFF)
- )
- cmake_src_configure
-}