summaryrefslogtreecommitdiff
path: root/sci-libs/libhomfly/libhomfly-1.02.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libhomfly/libhomfly-1.02.6.ebuild')
-rw-r--r--sci-libs/libhomfly/libhomfly-1.02.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/libhomfly/libhomfly-1.02.6.ebuild b/sci-libs/libhomfly/libhomfly-1.02.6.ebuild
new file mode 100644
index 000000000000..717bc354d1d4
--- /dev/null
+++ b/sci-libs/libhomfly/libhomfly-1.02.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=$(ver_rs 2 r)
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Library to compute the homfly polynomial of a link"
+HOMEPAGE="https://github.com/miguelmarco/libhomfly"
+SRC_URI="https://github.com/miguelmarco/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+DEPEND="dev-libs/boehm-gc"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure(){
+ econf $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}