summaryrefslogtreecommitdiff
path: root/sci-libs/linux-gpib
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/linux-gpib')
-rw-r--r--sci-libs/linux-gpib/Manifest1
-rw-r--r--sci-libs/linux-gpib/linux-gpib-4.3.6-r100.ebuild190
2 files changed, 191 insertions, 0 deletions
diff --git a/sci-libs/linux-gpib/Manifest b/sci-libs/linux-gpib/Manifest
index bfd9e7a638c1..af10eefbd0b9 100644
--- a/sci-libs/linux-gpib/Manifest
+++ b/sci-libs/linux-gpib/Manifest
@@ -3,5 +3,6 @@ DIST gpib_firmware-2008-08-10.tar.gz 173004 BLAKE2B 05fcde09de5246b86004c263c733
DIST linux-gpib-4.3.5.tar.gz 1462624 BLAKE2B fff30ed1a7abc18cd4317e8f8979ef4014a532baab8c014f9a2eaa3338a2e8e8b672214d3f2b3f44066be15f432861a3fe3d67652f6966e73e561d99ff1e1566 SHA512 018cc255922a6335f8d28418b0a0808c3a369506470d9c81432ac7183ae255217d938a419e10ba2b0c44205a9d901405ce00ad5bdd968db2721cedd83baa2f76
DIST linux-gpib-4.3.6.tar.gz 1433121 BLAKE2B 64e2b19106d0531df990b1338f82a71707e54f448d652f6379eb9cd71feb84637090ed8fdfb0264248aa6879d5b9a1dc50e75c21a2c22a31397120eea5903e98 SHA512 a8005c71bfddb854ecbe4df0a81530e44378150242508b10df58c61d039c6d329020407608e31f1ef360de0c83169e76b793c032256e732d229bfd2da4cbaa35
EBUILD linux-gpib-4.3.5.ebuild 4998 BLAKE2B 58df8bb468d2902ff2cfd10b5b1d70bdca6da62a5abae0e9d70e462de077667be0bd85236a6c97fb30c77b0f4f0eb1be8ffd8cae5c2ea64e82f6fda89168d698 SHA512 52f525242338765586e3a25ba39a830357d9717badb8be6202a0a37a5e4155daaaeaa8f4f5d33225ac5a1182586cbf7f6e9f7b9a268c00a2176fa801ed12451e
+EBUILD linux-gpib-4.3.6-r100.ebuild 5030 BLAKE2B c8413eab2fa8182d0eb143b284291dcc021344309f5d8e1968774bbb67db6c99247f9e2a282ee53ecb2efa7ee45f934fe59646a7883650321b6c46f24dc2e3a5 SHA512 29bb81d27ea873811be6bd2f8aed3f122ea91c0081a085f8b6e5698e4efabf1a490e57630b37e5c2d3e529e52fa39cbd2e403b47598f9e073b2da4e2169f341e
EBUILD linux-gpib-4.3.6-r3.ebuild 5105 BLAKE2B 69d0c1d530c7520a105d35f70d53195346181e52a539c92be2ae93c27e930475c89c8ad619b67ab4e4d053189df2a8517f1724a08532d6e564e057e7aa118271 SHA512 9d227039921307f310ecc48ba83717fc73847069de4a6a3e9b114e133ef2bfa7405e9796a643c0682cfd0bc0fdbf52991b82c831147cb1c9fdeb4611e727c93f
MISC metadata.xml 548 BLAKE2B c976143b910efb6a8920f064f35fdac9cb325ff272aca8a7644511300f4dfe9232c280577a90eae225ca4f88bc2b4cd09d175d4190bc13513d89457f57c9bb52 SHA512 c611a420ab28d623b5b9167bd59c04c2fe27404a7fd85de72a555f99ef8bad4383702482ae808d4eb66014a9e63ca057aa7195748f9c230f0778fcbde07fb71f
diff --git a/sci-libs/linux-gpib/linux-gpib-4.3.6-r100.ebuild b/sci-libs/linux-gpib/linux-gpib-4.3.6-r100.ebuild
new file mode 100644
index 000000000000..7950a9d28862
--- /dev/null
+++ b/sci-libs/linux-gpib/linux-gpib-4.3.6-r100.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_COMPAT=( 2-2 3-0 )
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit readme.gentoo-r1 autotools guile-single perl-functions python-single-r1 udev
+
+# Check for latest firmware version on bump
+FW_PV="2008-08-10"
+
+DESCRIPTION="Driver library for GPIB (IEEE 488.2) hardware"
+HOMEPAGE="https://linux-gpib.sourceforge.io/"
+SRC_URI="https://downloads.sourceforge.net/linux-gpib/${P}.tar.gz
+ firmware? ( https://linux-gpib.sourceforge.io/firmware/gpib_firmware-${FW_PV}.tar.gz )
+"
+S="${WORKDIR}/${PN}-user-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="pcmcia static guile perl php python tcl doc firmware"
+REQUIRED_USE="
+ guile? ( ${GUILE_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+COMMONDEPEND="
+ sys-libs/readline:=
+ tcl? ( dev-lang/tcl:0= )
+ guile? ( ${GUILE_DEPS} )
+ perl? ( dev-lang/perl:= )
+ php? ( dev-lang/php:= )
+ python? ( ${PYTHON_DEPS} )
+ firmware? ( sys-apps/fxload )
+"
+RDEPEND="${COMMONDEPEND}
+ acct-group/gpib
+ ~sci-libs/linux-gpib-modules-${PV}
+"
+DEPEND="${COMMONDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-perl.patch
+)
+
+pkg_setup() {
+ use guile && guile-single_pkg_setup
+ use perl && perl_set_version
+ use python && python_setup
+}
+
+src_unpack() {
+ default
+ unpack "${WORKDIR}/${P}/${PN}-user-${PV}.tar.gz"
+}
+
+src_prepare() {
+ default
+
+ use guile && guile_bump_sources
+
+ # We have to use --root instead of --prefix for setup.py.
+ # Otherwise the python files are not installed properly into site-packages.
+ sed -i -e \
+ 's/--prefix=$(DESTDIR)$(prefix)/--root=$(DESTDIR)/g' \
+ language/python/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static) \
+ $(use_enable guile guile-binding) \
+ $(use_enable perl perl-binding) \
+ $(use_enable php php-binding) \
+ $(use_enable python python-binding) \
+ $(use_enable tcl tcl-binding) \
+ $(use_enable doc documentation)
+}
+
+src_install() {
+ # PYTHONDONTWRITEBYTECODE=0 is required, otherwise
+ # installation of the python files is skipped
+ FIRM_DIR="${EPREFIX}"/usr/share/usb
+ emake \
+ DESTDIR="${ED}" \
+ INSTALL_MOD_PATH="${ED}" \
+ HOTPLUG_USB_CONF_DIR=/etc/hotplug/usb \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ USB_FIRMWARE_DIR=${FIRM_DIR} \
+ PYTHONDONTWRITEBYTECODE=0 \
+ docdir="/usr/share/doc/${PF}/html" install
+
+ use guile && guile_unstrip_ccache
+
+ if use perl; then
+ einfo "Installing perl module"
+ cd "${S}"/language/perl || die
+ emake DESTDIR="${ED}" install
+ perl_fix_packlist
+ perl_delete_emptybsdir
+ cd "${S}" || die
+ fi
+
+ echo "KERNEL==\"gpib[0-9]*\", MODE=\"0660\", GROUP=\"gpib\"" >> 99-gpib.rules || die
+ udev_dorules 99-gpib.rules
+
+ dodoc doc/linux-gpib.pdf ChangeLog AUTHORS README* NEWS
+
+ insinto /etc
+ newins util/templates/gpib.conf gpib.conf
+ newins util/templates/gpib.conf gpib.conf.example
+
+ if use pcmcia; then
+ insinto /etc/pcmcia
+ doins "${S}"/etc/pcmcia/*
+ fi
+
+ # remove .la files
+ find "${ED}" -name '*.la' -delete || die
+
+ DOC_CONTENTS="
+As the udev rules were changed and refactored in this release it is
+necessary to remove any manually installed pre-4.3.0 gpib udev rules files
+in /etc/udev/rules.d/. The files to remove are:
+\n
+ 99-agilent_82357a.rules\n
+ 99-gpib-generic.rules\n
+ 99-ni_usb_gpib.rules\n
+\n
+You need to run the 'gpib_config' utility to setup the driver before
+you can use it. In order to do it automatically you can add to your
+start script something like this (supposing the appropriate driver
+is loaded on the startup):
+\n
+ gpib_config --minor 0
+\n
+To give a user access to the computer's gpib board you will have to add
+them to the group 'gpib' or, you could change the permissions on the device
+files /dev/gpib[0-15] to something you like better, using 'chmod'
+\n
+Edit /etc/gpib.conf to match your interface board, and any devices you wish
+to open via ibfind(). See the documentation in /usr/share/linux-gpib/html for
+more information.
+\n
+"
+
+ if use pcmcia; then
+ DOC_CONTENTS+='
+For PCMCIA cards:\n
+All files needed for a PCMCIA board were copied to /etc/pcmcia.
+You may wish to edit the options passed to the gpib_config call in the
+/etc/pcmcia/linux-gpib-pcmcia script.
+You may need to send a SIGHUP signal to the cardmgr daemon to force it
+to reload the files in /etc/pcmcia \(alternatively you could use your
+pcmcia init.d script to restart the cardmgr, or you could just reboot\).
+The driver module will be loaded as needed by the cardmgr.
+
+'
+ fi
+
+ if use firmware; then
+ DOC_CONTENTS+='
+For Agilent \(HP\) 82341C and 82341D cards:
+The firmware for these boards is uploaded by passing the appropriate
+firmware file from /usr/share/linux-gpib/hp_82341 directory to
+gpib_config using the -I or --init-data command line option. Example:\n
+gpib_config --minor 0 --init-data /usr/share/linux-gpib/hp_82341/hp_82341c_fw.bin
+'
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}