summaryrefslogtreecommitdiff
path: root/sci-libs/mpfi/mpfi-1.5.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mpfi/mpfi-1.5.4.ebuild')
-rw-r--r--sci-libs/mpfi/mpfi-1.5.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/mpfi/mpfi-1.5.4.ebuild b/sci-libs/mpfi/mpfi-1.5.4.ebuild
new file mode 100644
index 000000000000..7c513767c675
--- /dev/null
+++ b/sci-libs/mpfi/mpfi-1.5.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Multiple precision interval arithmetic library based on MPFR"
+HOMEPAGE="http://perso.ens-lyon.fr/nathalie.revol/software.html"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/38111/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}