summaryrefslogtreecommitdiff
path: root/sci-libs/onnx/onnx-1.13.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/onnx/onnx-1.13.1-r1.ebuild')
-rw-r--r--sci-libs/onnx/onnx-1.13.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/onnx/onnx-1.13.1-r1.ebuild b/sci-libs/onnx/onnx-1.13.1-r1.ebuild
new file mode 100644
index 000000000000..1de081f5931b
--- /dev/null
+++ b/sci-libs/onnx/onnx-1.13.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1 cmake
+
+DESCRIPTION="Open Neural Network Exchange (ONNX)"
+HOMEPAGE="https://github.com/onnx/onnx"
+SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-libs/protobuf:="
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.14.0-cxx_14.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+}