summaryrefslogtreecommitdiff
path: root/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ta-lib/ta-lib-0.4.0.ebuild')
-rw-r--r--sci-libs/ta-lib/ta-lib-0.4.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/ta-lib/ta-lib-0.4.0.ebuild b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
new file mode 100644
index 000000000000..99cb7258bb33
--- /dev/null
+++ b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="Technical Analysis Library for analyzing financial markets trends"
+HOMEPAGE="http://www.ta-lib.org/"
+SRC_URI="mirror://sourceforge/ta-lib/${P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+S="${WORKDIR}"/${PN}
+
+PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_test() {
+ ewarn "Note: this testsuite will fail without an active internet connection."
+ "${S}"/src/tools/ta_regtest/ta_regtest || die "Failed testsuite."
+}