summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin43139 -> 43144 bytes
-rw-r--r--sci-libs/datasets/Manifest2
-rw-r--r--sci-libs/datasets/datasets-2.19.2.ebuild43
3 files changed, 42 insertions, 3 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 10f59af68614..f9db87566048 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/datasets/Manifest b/sci-libs/datasets/Manifest
index 4f23d13dee02..6d9756e49a7d 100644
--- a/sci-libs/datasets/Manifest
+++ b/sci-libs/datasets/Manifest
@@ -1,4 +1,4 @@
AUX datasets-2.19.2-tests.patch 756 BLAKE2B d9bb33c2aa03f06bb42342da3bfefa0d916d7979c06725cf2c667df3d8ac4a03eb79e5129b6d0f7d232b4eb64a0cb993451e7da7661e692f50f8b8708aa8d8e2 SHA512 7ac8f060e6808b6d409508d7a9a8de4626d71b443db1df4e2489cdf3f61ab48e169ba336d8f8f6c78decb25c524ef5a291db0265813888a29c70661b04757d49
DIST datasets-2.19.2.gh.tar.gz 2176600 BLAKE2B d02d43f7db0ce9a2220b332e5e2ab4de2648fa2b693dec703ae900b42d0089be1cf79270d4b8daeda841cccde6f60c93d6b2eee15bc652e4f60e08a6f3fade82 SHA512 7593463174b7308c45e1fd50190942e94ac63ff7bd0ff54a8a09496d041f69fa43eaa7e4e7372965deaafdb7843d8a86aeb0db1a75efe0c3da37fcf064521c16
-EBUILD datasets-2.19.2.ebuild 10626 BLAKE2B 35d3f0629a491eb1ee76f9d224fa36a412b62f28c99d00d4c62dd9f0c000b30b8762feb635c69c8213fc776a79bb2d17fb1bfdd28d79bdc2170121ac3ac40d4b SHA512 29cc2049c49611b2d472123b98cbc64fcee1f5e7a4d918d4d756dd337be6aa5cb3bc5a8f9e0ed55a8838dcfa68196a55b8c0bf61617d0eab1576eefdcb788226
+EBUILD datasets-2.19.2.ebuild 13820 BLAKE2B 78e3179d5203fbb9a3459aadff3385c74e945938dc26ee5514ed0877e0829a0c40e0a2fa96306fee6ee9271b1d345818ae2aa8739275524a6f25439b53667a01 SHA512 124c17779dd53e599bb8804e791b75fa972ae75646eb4e228d750f809f6f0096209b8a406398a0d7328e6f8ae9b2a167f8e11a80d66d2bcaea767f9785d30ef1
MISC metadata.xml 379 BLAKE2B 48ebb9e7bfa8b58b0d15b82c4146def465e08cf3212ab4af04129d09c153b67b00d0fa05b94d6af54f643ec3a202f2335d3254b966f49d1394d3c7b9e5da56a5 SHA512 99560decfaa0e438980f372d99257695e9ca9585167d9aba091e0b775c2f8384657ddc017841c8f06f8b568017a54fb9e31da736f3c875da717e154cdce876d1
diff --git a/sci-libs/datasets/datasets-2.19.2.ebuild b/sci-libs/datasets/datasets-2.19.2.ebuild
index 73eed0dccf5f..4b10e92c523a 100644
--- a/sci-libs/datasets/datasets-2.19.2.ebuild
+++ b/sci-libs/datasets/datasets-2.19.2.ebuild
@@ -72,6 +72,7 @@ src_test() {
local EPYTEST_IGNORE=(
tests/test_upstream_hub.py
tests/packaged_modules/test_spark.py
+ tests/test_load.py
)
local EPYTEST_DESELECT=(
@@ -105,6 +106,14 @@ src_test() {
"tests/test_distributed.py::test_torch_distributed_run_streaming_with_num_workers"
"tests/test_file_utils.py::TestxPath::test_xpath_glob"
"tests/test_file_utils.py::TestxPath::test_xpath_rglob"
+ "tests/test_file_utils.py::test_xopen_remote"
+ "tests/test_file_utils.py::test_xexists_private"
+ "tests/test_file_utils.py::test_xlistdir_private"
+ "tests/test_file_utils.py::test_xisdir_private"
+ "tests/test_file_utils.py::test_xisfile_private"
+ "tests/test_file_utils.py::test_xgetsize_private"
+ "tests/test_file_utils.py::test_xglob_private"
+ "tests/test_file_utils.py::test_xwalk_private"
"tests/test_fingerprint.py::TokenizersHashTest::test_hash_regex"
"tests/test_fingerprint.py::TokenizersHashTest::test_hash_tokenizer"
"tests/test_fingerprint.py::TokenizersHashTest::test_hash_tokenizer_with_cache"
@@ -128,8 +137,15 @@ src_test() {
"tests/test_formatting.py::test_torch_formatter_sets_default_dtypes"
"tests/test_inspect.py::test_get_dataset_config_names[hf-internal-testing/librispeech_asr_dummy-expected4]"
"tests/test_inspect.py::test_get_dataset_default_config_name[hf-internal-testing/librispeech_asr_dummy-None]"
- "tests/test_load.py::ModuleFactoryTest::test_HubDatasetModuleFactoryWithParquetExport"
- "tests/test_load.py::ModuleFactoryTest::test_HubDatasetModuleFactoryWithParquetExport_errors_on_wrong_sha"
+ "tests/test_inspect.py::test_inspect_dataset"
+ "tests/test_inspect.py::test_inspect_metric"
+ "tests/test_inspect.py::test_get_dataset_config_info"
+ "tests/test_inspect.py::test_get_dataset_config_info_error[paws-None-ValueError]"
+ "tests/test_inspect.py::test_get_dataset_config_names"
+ "tests/test_inspect.py::test_get_dataset_default_config_name"
+ "tests/test_inspect.py::test_get_dataset_info"
+ "tests/test_inspect.py::test_get_dataset_split_names"
+ "tests/test_inspect.py::test_get_dataset_config_info_private"
"tests/test_metric_common.py::LocalMetricTest::test_load_metric_bertscore"
"tests/test_metric_common.py::LocalMetricTest::test_load_metric_bleurt"
"tests/test_metric_common.py::LocalMetricTest::test_load_metric_chrf"
@@ -157,6 +173,8 @@ src_test() {
"tests/test_metric_common.py::LocalMetricTest::test_load_metric_wiki_split"
"tests/test_metric_common.py::LocalMetricTest::test_load_metric_xnli"
"tests/test_metric_common.py::LocalMetricTest::test_load_metric_xtreme_s"
+ "tests/test_metric_common.py::LocalMetricTest::test_load_metric_bleu"
+ "tests/commands/test_test.py::test_test_command"
"tests/features/test_array_xd.py::ExtensionTypeCompatibilityTest::test_array2d_nonspecific_shape"
"tests/features/test_array_xd.py::ExtensionTypeCompatibilityTest::test_extension_indexing"
"tests/features/test_array_xd.py::ExtensionTypeCompatibilityTest::test_multiple_extensions_same_row"
@@ -189,6 +207,27 @@ src_test() {
"tests/features/test_image.py::test_formatted_dataset_with_image_feature_undecoded"
"tests/packaged_modules/test_cache.py::test_cache_multi_configs"
"tests/packaged_modules/test_cache.py::test_cache_single_config"
+ "tests/packaged_modules/test_cache.py::test_cache_capital_letters"
+ "tests/packaged_modules/test_folder_based_builder.py::test_data_files_with_different_levels_no_metadata"
+ "tests/packaged_modules/test_folder_based_builder.py::test_data_files_with_one_label_no_metadata"
+ "tests/test_data_files.py::test_DataFilesList_from_patterns_locally_with_extra_files"
+ "tests/test_data_files.py::test_DataFilesDict_from_patterns_locally_or_remote_hashing"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_natural_questions/default@19ba7767b174ad046a84f46af056517a3910ee57"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wiki40b/en@7b21a2e64b90323b2d3d1b81aa349bb4bc76d9bf"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wiki_dpr/psgs_w100.multiset.no_index@b24a417d802a583f8922946c1c75210290e93108"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wiki_dpr/psgs_w100.nq.compressed@b24a417d802a583f8922946c1c75210290e93108"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wiki_dpr/psgs_w100.nq.no_index@b24a417d802a583f8922946c1c75210290e93108"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wikipedia/20220301.de@4d013bdd32c475c8536aae00a56efc774f061649"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wikipedia/20220301.en@4d013bdd32c475c8536aae00a56efc774f061649"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wikipedia/20220301.fr@4d013bdd32c475c8536aae00a56efc774f061649"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wikipedia/20220301.frr@4d013bdd32c475c8536aae00a56efc774f061649"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wikipedia/20220301.it@4d013bdd32c475c8536aae00a56efc774f061649"
+ "tests/test_hf_gcp.py::TestDatasetOnHfGcp::test_dataset_info_available_wikipedia/20220301.simple@4d013bdd32c475c8536aae00a56efc774f061649"
+ "tests/test_hf_gcp.py::test_as_dataset_from_hf_gcs"
+ "tests/test_hf_gcp.py::test_as_streaming_dataset_from_hf_gcs"
+ "tests/test_iterable_dataset.py::test_iterable_dataset_from_hub_torch_dataloader_parallel"
+ "tests/test_offline_util.py::test_offline_with_timeout"
+ "tests/io/test_parquet.py::test_parquet_read_geoparquet"
)
distutils-r1_src_test
}