summaryrefslogtreecommitdiff
path: root/sci-mathematics/arb
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/arb')
-rw-r--r--sci-mathematics/arb/Manifest2
-rw-r--r--sci-mathematics/arb/arb-2.16.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-mathematics/arb/Manifest b/sci-mathematics/arb/Manifest
index 678fe3f2e342..2061a95c8954 100644
--- a/sci-mathematics/arb/Manifest
+++ b/sci-mathematics/arb/Manifest
@@ -1,4 +1,6 @@
AUX arb-2.11.1-pie-ftbs.patch 585 BLAKE2B cf7fd0230dd00a52452b1ad80f284028eab6c35c8aeb160e3f74b924a7c6e422a0740a3954eb2937b5b13085e47a25abc6c8f9dede88bd5f90cac5570c6b2710 SHA512 f147d61a6c9dfac57ded28a7265db9e6be76ebb8c9c787960d4dafc36ef703cebc42ba4a3ca8ef03ae3b81589d6a6a555a7ff381ddc9fd391466156677e0b4ff
DIST arb-2.11.1.tar.gz 1248835 BLAKE2B 8ba11f3a92103231c4710c0158ce0811b2a01872e1ec7b7a4a4320d27ab86688aa8733df6dd2464aa55c0a506a8a595e4c370848c78b5c3a650e647f0c6d7411 SHA512 7a014da5208b55f20c7a3cd3eb51070b09ae107b04cbbd6329925780c2ab4d7c38e1fb3619f21456fa806939818370fcae921f59eb013661b6bdd3d0971e3353
+DIST arb-2.16.0.tar.gz 1526059 BLAKE2B 14f4a9b23fa6fc46659b742cc95b4970cee74cf52bda8bc696831b0a5c1f946f41f1c2bba180ad1199c55d741366b3376aeed0efbf6ee087b26f6de788519739 SHA512 171c965aeb03cd2830df8a53990403c6da480a94d44385dadfbb2d02697f7c03e8b9a217094b0ad93f796d889a1564f4b9ae9db35ef9de90f61bb2e3220911be
EBUILD arb-2.11.1-r1.ebuild 1584 BLAKE2B 51a0f06c3357d1fedd7435d362b4f0cba35b4c479a23af1290989b7bbbec14fb61a6cce90292b793ee3692741cf949c501a89806d6f4f0e2b2d0070b268b152b SHA512 a489c8422518fdcb774e42b77c176301d64fc2c4d76ea8dc5865556ad2a1ce6ec562fed29e7c913c37fc69281d9b2d34fd62d2aaf5936e0fc0a6ed7679df0df8
+EBUILD arb-2.16.0.ebuild 1534 BLAKE2B 757103d7596a6b8e82675a480845dd4ef7b391efdc5b43d04963df4bdbd5c4d92603c7e7f67e06a8bc9455ed7d8ac809bd8082e76bccd80a749c2710a64bd262 SHA512 a544ff3bb4be78fb154e8d5988c8eb591bd96928ec163fae68f070ad9d2e6d67664c2d9d00972e48574bd136a6f1c24e4d95287da329fbf8bf1b842380b080bf
MISC metadata.xml 756 BLAKE2B da8035991c582b71f7bb25866fd86ad79c40640f5685436935bfd6efb26af9e11a31fb28ea83df5ef7f0951ecb26155021d289e0b9926aba03c8c7d9e417677f SHA512 843e473b1cb261c97f817d2c003f632c973a67ba1d8cfe188a40f41cc89fe6167917e2b669768420a7c7c88b19f5b4b68ba4529ab73e373c6696786ecfad11b6
diff --git a/sci-mathematics/arb/arb-2.16.0.ebuild b/sci-mathematics/arb/arb-2.16.0.ebuild
new file mode 100644
index 000000000000..72f391958855
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.16.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="http://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ >=sci-mathematics/flint-2.5.0:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Not an autoconf configure script.
+ # Note that it appears to have been cloned from the flint configure script
+ # and that not all the options offered are valid.
+ tc-export CC AR CXX
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --with-flint="${EPREFIX}/usr" \
+ --with-gmp="${EPREFIX}/usr" \
+ --with-mpfr="${EPREFIX}/usr" \
+ $(use_enable static-libs static) \
+ CFLAGS="${CPPFLAGS} ${CFLAGS}" || die
+}
+
+src_compile() {
+ emake verbose
+}
+
+src_test() {
+ # Have to set the library path otherwise a previous install of libarb may be loaded.
+ # This is in part a consequence of setting the soname/installnae I think.
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ DYLD_LIBRARY_PATH="${S}" emake AT= QUIET_CC= QUIET_CXX= QUIET_AR= check
+ else
+ LD_LIBRARY_PATH="${S}" emake AT= QUIET_CC= QUIET_CXX= QUIET_AR= check
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
+ use static-libs || prune_libtool_files --all
+ dodoc README.md
+}