summaryrefslogtreecommitdiff
path: root/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild')
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
new file mode 100644
index 000000000000..4beb16299f8c
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and command-line interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/msoos/${PN}.git"
+else
+ SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 MIT"
+SLOT="0/${PV}"
+RESTRICT="test" # Tests require some git modules.
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOBREAKID=ON
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}