summaryrefslogtreecommitdiff
path: root/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/dunshire/dunshire-0.1.1.ebuild')
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/dunshire/dunshire-0.1.1.ebuild b/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
new file mode 100644
index 000000000000..fd21e23a8a9a
--- /dev/null
+++ b/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to solve linear games over symmetric cones"
+HOMEPAGE="http://michael.orlitzky.com/code/dunshire"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ local DOCS=( doc/README.rst )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}