summaryrefslogtreecommitdiff
path: root/sci-mathematics/glpk
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/glpk')
-rw-r--r--sci-mathematics/glpk/Manifest1
-rw-r--r--sci-mathematics/glpk/glpk-5.0-r1.ebuild101
2 files changed, 0 insertions, 102 deletions
diff --git a/sci-mathematics/glpk/Manifest b/sci-mathematics/glpk/Manifest
index d42a3e0811d9..4277567f5fd6 100644
--- a/sci-mathematics/glpk/Manifest
+++ b/sci-mathematics/glpk/Manifest
@@ -2,6 +2,5 @@ AUX glpk-4.65-debundle-system-libs.patch 1930 BLAKE2B 0c265afe9338e75bb3d6536e9e
AUX glpk-4.65-fix-mysql-include-prefix.patch 1837 BLAKE2B ecd90024e07f29e8ebb6af80b520c8f192cfea21c90d8c247001389f2ccfcf24ad487981a0cc719d1ca99e266dd2a9d66f6416d4f2d5e7c80bdf807b9bb7b74e SHA512 c74281bf3e03e136d183b562b8f682a3e1957019a36ec0c6a048049f0d5f55361107a62e36eaa9e3306a1f13df10adf55c2f54f096b6e353108856e05d9ce799
AUX glpk-5.0-aliasing.patch 2997 BLAKE2B 8d67fd1a4eba4af91281d7858e2ae0faed74bce92be981f842ff4b7e2cc84ec465fa82acc0f605fc0cd6310881b5c90baae3001a474b71b2ce2d4d2c689fb46d SHA512 392bfcb2c7319899abdc414b59e7f95beeefc4cabad7603d79734eeca8665a6a99e373a97c0e88a5bce923090d2c3ae8cae0845c2222c389090d3b9009e02e92
DIST glpk-5.0.tar.gz 4132649 BLAKE2B f8204f66a97af950c13ee72ee9541f305745741d1231325670ede14663cb6c28ec6fbc44b3625973f1924ca078183d1d43f494ad43a7b48b45be131882b00001 SHA512 4e92195fa058c707146f2690f3a38b46c33add948c852f67659ca005a6aa980bbf97be96528b0f8391690facb880ac2126cd60198c6c175e7f3f06cca7e29f9d
-EBUILD glpk-5.0-r1.ebuild 2573 BLAKE2B 86b24b612643deb53ad466534cb640831549eb1412cf379bae02307a9957c693716050cb35770ec891d50d91ffbf3fa218ec7fc43400d9234c49637ae6a4064f SHA512 c20ba1c1eb265a9667979cdf286bb69e9e032454ffdfade04d5700806c6473313efe428c6321ee9db43751a19ff11520315aae7b4e9b41ab921c0fabe1c08355
EBUILD glpk-5.0-r3.ebuild 2570 BLAKE2B 0890149920f0cc5a09328dae3f9d9f4bbad688f432363f7efa15594768bfded21c353a97906f024f7b1eeb77c1389fca5152a2b2fb6721d66ca3e02c22248f59 SHA512 945624c929e87b8a54a83d670a77e5a3aa4171eb3fccf26358b73a914a030e85df21b364b4ec5cbd9c6a622baea420d56db7efb7b0153ec25b7f68d5e08b0eee
MISC metadata.xml 1104 BLAKE2B f22121178a0e7f3ab097558b05cb084a7dc787cc1530859d6182aea61abee220e135ad695f517419053bb805cecef9c3555fcdb2688d6b6d17cdd8b3ce2dbb21 SHA512 965c2c6c322c488736cb9743f1e076fdf2733976502b2b2668717534f7a1505f36b84f453f23f4ff5972f7a25883d253e345caef727bab8abed4c638f5a0dc5a
diff --git a/sci-mathematics/glpk/glpk-5.0-r1.ebuild b/sci-mathematics/glpk/glpk-5.0-r1.ebuild
deleted file mode 100644
index a0db9eee70b6..000000000000
--- a/sci-mathematics/glpk/glpk-5.0-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic toolchain-funcs
-
-DESCRIPTION="GNU Linear Programming Kit"
-HOMEPAGE="https://www.gnu.org/software/glpk/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0/40"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples gmp odbc mysql"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="
- sci-libs/amd:0=
- sci-libs/colamd:=
- sys-libs/zlib:0=
- gmp? ( dev-libs/gmp:0= )
- mysql? ( dev-db/mysql-connector-c )
- odbc? (
- || (
- dev-db/libiodbc:0
- dev-db/unixODBC:0
- )
- )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.65-fix-mysql-include-prefix.patch
- "${FILESDIR}"/${PN}-4.65-debundle-system-libs.patch
-)
-
-src_prepare() {
- # TODO: the ODBC library is dlopen()ed, so we only want to append
- # -I<foo> to the preprocessor flags, and not all of the CFLAGS that
- # were used to build libiodbc. That fix and the pkg-config fallback
- # should be sent upstream, and placed into CPPFLAGS rather than
- # CFLAGS (as configure.ac does now).
- use odbc && [[ -z $(type -P odbc_config) ]] && \
- append-cppflags $($(tc-getPKG_CONFIG) --cflags libiodbc)
-
- default
-
- eautoreconf
-}
-
-src_configure() {
- # -Werror=strict-aliasing
- # https://bugs.gentoo.org/863047
- # https://lists.gnu.org/archive/html/bug-glpk/2022-08/msg00000.html
- # No upstream response...
- #
- # Do not trust it to LTO either.
- append-flags -fno-strict-aliasing
- filter-lto
-
- local myconf
- if use mysql || use odbc; then
- myconf="--enable-dl"
- else
- myconf="--disable-dl"
- fi
-
- econf ${myconf} \
- --disable-static \
- $(use_enable mysql) \
- $(use_enable odbc) \
- $(use_with gmp)
-}
-
-src_install() {
- default
-
- if use examples; then
- # The top-level Makefile descends into the "examples" directory
- # unconditionally, building a program and excreting build
- # artifacts that we don't want to install. Note: this still
- # leaves the example program /usr/bin/glpsol installed. An
- # additional "emake ... uninstall" could probably take care
- # of that if desired.
- emake -C examples clean
-
- # Installing the Makefiles for the examples does the user no
- # good without the top-level Makefile.
- rm examples/Makefile{.in,.am,} \
- || die "failed to remove example Makefiles"
-
- insinto "/usr/share/doc/${PF}"
- doins -r examples
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-
- use doc && dodoc doc/*.pdf doc/notes/*.pdf doc/*.txt
-
- # no static archives
- find "${D}" -name '*.la' -delete || die
-}