summaryrefslogtreecommitdiff
path: root/sci-mathematics/planarity/planarity-3.0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/planarity/planarity-3.0.1.0.ebuild')
-rw-r--r--sci-mathematics/planarity/planarity-3.0.1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-mathematics/planarity/planarity-3.0.1.0.ebuild b/sci-mathematics/planarity/planarity-3.0.1.0.ebuild
new file mode 100644
index 000000000000..ff50336d2e9e
--- /dev/null
+++ b/sci-mathematics/planarity/planarity-3.0.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The edge addition planarity suite of graph algorithms"
+HOMEPAGE="https://github.com/graph-algorithms/edge-addition-planarity-suite/"
+
+SRC_URI="https://github.com/graph-algorithms/edge-addition-planarity-suite/releases/download/Version_${PV}/${P}.tar.gz"
+IUSE="static-libs"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}