summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19008 -> 19005 bytes
-rw-r--r--sci-mathematics/cadabra/Manifest2
-rw-r--r--sci-mathematics/cadabra/cadabra-2.4.4.1.ebuild104
-rw-r--r--sci-mathematics/coq/Manifest6
-rw-r--r--sci-mathematics/coq/coq-8.12.0-r2.ebuild90
-rw-r--r--sci-mathematics/coq/coq-8.18.0.ebuild (renamed from sci-mathematics/coq/coq-8.17.0.ebuild)2
6 files changed, 109 insertions, 95 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 6a2be961aecc..9bf142b95a54 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/cadabra/Manifest b/sci-mathematics/cadabra/Manifest
index 219683d44faa..610bb849d150 100644
--- a/sci-mathematics/cadabra/Manifest
+++ b/sci-mathematics/cadabra/Manifest
@@ -1,4 +1,6 @@
AUX cadabra2-CMake.patch 3184 BLAKE2B afa702834d5eb82a8056307b419fc20bbc2d45b0474994328b70fee383dff415ea37ef2e70c83e9cb7776e06f9295cf5cb9afddddaf857227f7a72f362b61726 SHA512 ddd6b451f81e465d4fef9401340808922bcb1074895173d83d699614e0c967024863848fabdd207f7124ff6396e8c2c75d2ed1425ba73d7bb6d5ac6fe56a87f1
DIST cadabra-2.4.3.2.tar.gz 25157173 BLAKE2B 895b91a01f5dedc87294903959ee3aca0234016fce0094f4288c07e2d265f90f834670b9c50dcfa059e46564c773f73f049cf65db74f49932e442d15d68ecd88 SHA512 21c76804442397fa3d5fa407fc74395fc800d01c2a5d84270e9cf3abd875c8ff96e2ba8f8349037797ff4ef3d2b9033c2a1a6af45bb75c3a201acdd7357adb6f
+DIST cadabra-2.4.4.1.tar.gz 25171405 BLAKE2B 7505b5b56c4b9f18c63535cac1854a8926f985729ac9b284146d7d604c4774436510f1fa04c615efb4e06ae4b077859e391046b2d07565586afc0d9dac66156a SHA512 9e81889dabeff1ad93f4d8fc01960c11747d2a19d0cb6d8f872cff217ffe7bd6b92fcd5ce49cf5f2c089c440a3abdb0358f5f470b4de616ce17c42a23864caf6
EBUILD cadabra-2.4.3.2-r1.ebuild 2329 BLAKE2B 877d2060a10c388f43d1723f0830cfdb9a67426af825d7fb16709978b8f1f77888de668f676c76f60e652252261074e60b8087cf144e8f0d1add2db74656e67e SHA512 d081f07f31259e6bf596f6ed3e0362e426b83e02aa99d51cf51601f1654bead5c1d6e5e8a1bd0be000b2237018eab41c9cd00cb6141a76473bed3f1cbaec106f
+EBUILD cadabra-2.4.4.1.ebuild 2330 BLAKE2B 75e146ce8b7645923da52ef63bdf6968deaeec31a2b1d8e0346d2571b4146d26d55275d97a4386ceeabc56bd48d1c10eb2a3dded7d1c702e64e01b6341b69d98 SHA512 f7e05f2a6485c42c3a722f01e5b04444575e3c623f141f8c1befb53795f138fa888a653816287e7a4dd14a4a81f6baa63a8b5c7436041244c0a319402e5b4924
MISC metadata.xml 1342 BLAKE2B 2f34aae73fc01d4b8fd4326505b7b0785663c62593641d1d0a01f64adc12cbc8676271612ce91258927ac22957a8d5aba53dd2627130582c744bc32c28e0e207 SHA512 41dffbcfae16f8f0702df5a1837b225100761d48817a2d70fa03aca6246b9d3184d60989cf265282286b02a77a126ac82695c2d74c6de91da45e8f64fcb91811
diff --git a/sci-mathematics/cadabra/cadabra-2.4.4.1.ebuild b/sci-mathematics/cadabra/cadabra-2.4.4.1.ebuild
new file mode 100644
index 000000000000..4452c72b8c88
--- /dev/null
+++ b/sci-mathematics/cadabra/cadabra-2.4.4.1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR=$(ver_cut 1)
+CADABRA=${PN}${MAJOR}
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit xdg-utils python-single-r1 cmake
+
+DESCRIPTION="Field-theory motivated approach to computer algebra"
+HOMEPAGE="https://cadabra.science/
+ https://github.com/kpeeters/cadabra2/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kpeeters/${CADABRA}.git"
+else
+ SRC_URI="https://github.com/kpeeters/${CADABRA}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${CADABRA}-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${MAJOR}"
+IUSE="gui +jupyter test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/dvipng
+ dev-cpp/glibmm:2
+ dev-db/sqlite:3=
+ dev-libs/boost:=
+ dev-libs/gmp:=[cxx]
+ dev-libs/jsoncpp:=
+ dev-libs/libsigc++:2
+ dev-texlive/texlive-basic
+ $(python_gen_cond_dep '
+ dev-python/gmpy:2[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ jupyter? ( dev-python/jupyter[${PYTHON_USEDEP}] )
+ ')
+ gui? ( dev-cpp/gtkmm:3.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="$(python_gen_cond_dep 'dev-python/pybind11[${PYTHON_USEDEP}]')"
+
+PATCHES=( "${FILESDIR}"/${CADABRA}-CMake.patch )
+
+DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md JUPYTER.rst README.rst )
+
+xdg_update() {
+ if use gui ; then
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ fi
+}
+
+src_prepare() {
+ # Clean postinst script which calls libtool and icon-cache update
+ echo '#!/bin/sh' > "${S}"/config/postinst.in || die
+
+ # Fix "PYTHON_EXECUTABLE" in Jupyter kernel
+ sed -i "s|@PYTHON_EXECUTABLE@|${EPYTHON}|" \
+ "${S}"/jupyterkernel/kernelspec/kernel.json.in || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DENABLE_SYSTEM_JSONCPP=ON
+ -DPACKAGING_MODE=ON
+ -DUSE_PYTHON_3=ON
+ -DBUILD_AS_CPP_LIBRARY=OFF
+ -DENABLE_JUPYTER=OFF # special Xeus Jupyter kernel (uses xtl)
+ -DENABLE_MATHEMATICA=OFF
+ -DINSTALL_TARGETS_ONLY=OFF
+ -DBUILD_TESTS=$(usex test)
+ -DENABLE_FRONTEND=$(usex gui)
+ -DENABLE_PY_JUPYTER=$(usex jupyter)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_update
+}
+
+pkg_postrm() {
+ xdg_update
+}
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index e186dc5b3f8f..6c84c01ca755 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,7 +1,5 @@
-DIST coq-8.12.0.tar.gz 6774001 BLAKE2B dc1d6adf9d4bd50d46007fbf5fd43d1ea97b6b226d89ad943419d4cb7df1439950c94b5e3cc614eb789103d1ab50535909d4ba2079eafc2caa4fd91db30e747d SHA512 8a64624c578ce0ab781fb3b1f162bd8b095735ad891fdad2fb7c40849afbdc7c1360187c6b62a5ef2982566f4c6c78029240c611ae769943a5250af300eb1240
-DIST coq-8.17.0.tar.gz 7504612 BLAKE2B 90ff0e187e13a6501580733f0e92dbaba0ddc520b418246c743f0c282e74cee3e1d69ad0249cddfd5b8f3ba363bc58cb91aad33d0936ae38afde0f4c97d47a72 SHA512 2f77bcb5211018b5d46320fd39fd34450eeb654aca44551b28bb50a2364398c4b34587630b6558db867ecfb63b246fd3e29dc2375f99967ff62bc002db9c3250
DIST coq-8.17.1.tar.gz 7506035 BLAKE2B 29b5b11666185ec293f50264f5a8ad66433c3ce05d74128b524f6fc3c6810551fe76d11d6f9db7d3741b829ac8bacb66948aad522d0cd2c487692c3df8b563ff SHA512 9a35311acec2a806730b94ac7dceabc88837f235c52a14c026827d9b89433bd7fa9555a9fc6829aa49edfedb24c8bbaf1411ebf463b74a50aeb17cba47745b6b
-EBUILD coq-8.12.0-r2.ebuild 1854 BLAKE2B 96a5bc026d7cef8218fa0f10401c697df908487a2a510f349a57d080e2c59c6fc6237223fbe82f5114c6ee70ebdfd9fffc9812bc2e8981febac635efd94b3035 SHA512 3936eafb537044833b310fafc9ba4595bb6deba71679177fbb807c59e3bfcd44f8a98c26077fda791619479b5efdefd64f6235ce2ae7c599489c4f0e8f8e003b
-EBUILD coq-8.17.0.ebuild 2317 BLAKE2B ff2958b7e82400115ab634dd00bac13df99ba088d8d2ec48ad61663ba0aa3690e3cad26badedad5fd12958df4c7a343b5c9d2d827a2a7aac3ba35e9ddfe3f222 SHA512 4c04bb4aa2d97dfa21868e6246d8a35d96b55e80c7bf6206ce1c67f46102c449cad25f7062c93c7defdb0e118be57c8f86d3c3323df53ce3c794617a7d4ed6d5
+DIST coq-8.18.0.tar.gz 7612742 BLAKE2B 2fb9f6205465ded60d2e1f7943f53ad884aea121c8129bb30c3f66c172f51f97eb553f8a745fd3ab1ec4da80d4ca08a7aea22f65d372fda3322c0f9ca7862923 SHA512 46922d5f2eb6802a148a52fd3e7f0be8370c93e7bc33cee05cf4a2044290845b10ccddbaa306f29c808e7c5019700763e37e45ff6deb507b874a4348010fed50
EBUILD coq-8.17.1.ebuild 2317 BLAKE2B ff2958b7e82400115ab634dd00bac13df99ba088d8d2ec48ad61663ba0aa3690e3cad26badedad5fd12958df4c7a343b5c9d2d827a2a7aac3ba35e9ddfe3f222 SHA512 4c04bb4aa2d97dfa21868e6246d8a35d96b55e80c7bf6206ce1c67f46102c449cad25f7062c93c7defdb0e118be57c8f86d3c3323df53ce3c794617a7d4ed6d5
+EBUILD coq-8.18.0.ebuild 2318 BLAKE2B 43895300c1c9b754f5c1d1cfc2140318f8ef32014bcfa59e47e21931efe8d9d115637791b0ddad99c6ecea9fefc172bfddaaef048cffe99ae769fdb807cef8eb SHA512 6f9149a727109283ec4f4ca883016478f0e77464542ca3798e068d3eea2d682eba1b226b37bdc1bc9e4c35c8c19997e1720f3abf2d42c6fc790d148137e0f8a4
MISC metadata.xml 1047 BLAKE2B 9f6defdf213139ee6549bc8f3b36ce5e8f53ea73bd5aad9262932cbaea7e90bd97c9ffc9dbbd03ac50097c5a6f19f5ddf00dd2b74cc6a5349faf1b597244fb67 SHA512 0f5bfbdd9ffd6f64379e697ed7cf90c2d9257cd1815e520aa14235f1cb399d20fc863221a0cae803cc88e5975be964b9debc3d750a6378ea157146f2e567c5dc
diff --git a/sci-mathematics/coq/coq-8.12.0-r2.ebuild b/sci-mathematics/coq/coq-8.12.0-r2.ebuild
deleted file mode 100644
index 2781f3840db2..000000000000
--- a/sci-mathematics/coq/coq-8.12.0-r2.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop multilib
-
-MY_PV=${PV/_p/pl}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE="gtk debug +ocamlopt doc"
-
-RESTRICT=test
-
-RDEPEND="
- dev-ml/camlp5:=[ocamlopt?]
- || (
- dev-ml/num
- <dev-lang/ocaml-4.09.0[ocamlopt?]
- )
- gtk? (
- dev-ml/lablgtk:3=[sourceview,ocamlopt?]
- dev-ml/lablgtk-sourceview:3=[ocamlopt?]
- )"
-DEPEND="${RDEPEND}
- dev-ml/findlib
- doc? (
- media-libs/netpbm[png,postscript(+),zlib(+)]
- virtual/latex-base
- dev-tex/hevea
- dev-texlive/texlive-latexrecommended
- dev-texlive/texlive-pictures
- dev-texlive/texlive-mathscience
- dev-texlive/texlive-latexextra
- )"
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- ocaml_lib=$(ocamlc -where)
- local myconf=(
- -prefix /usr
- -bindir /usr/bin
- -libdir /usr/$(get_libdir)/coq
- -mandir /usr/share/man
- -coqdocdir /usr/$(get_libdir)/coq/coqdoc
- -docdir /usr/share/doc/${PF}
- -configdir /etc/xdg/${PN}
- )
-
- use debug && myconf+=( -debug )
- use doc || myconf+=( -with-doc no )
-
- if use gtk; then
- if use ocamlopt; then
- myconf+=( -coqide opt )
- else
- myconf+=( -coqide byte )
- fi
- else
- myconf+=( -coqide no )
- fi
-
- use ocamlopt || myconf+=( -byte-only )
-
- export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
- ./configure ${myconf[@]} || die "configure failed"
-}
-
-src_compile() {
- emake STRIP="true" -j1 world VERBOSE=1
-}
-
-src_test() {
- emake STRIP="true" check VERBOSE=1
-}
-
-src_install() {
- emake STRIP="true" COQINSTALLPREFIX="${D}" install -j1 VERBOSE=1
- dodoc README.md CREDITS
-
- use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
-}
diff --git a/sci-mathematics/coq/coq-8.17.0.ebuild b/sci-mathematics/coq/coq-8.18.0.ebuild
index 495f48055a82..f634026e1cda 100644
--- a/sci-mathematics/coq/coq-8.17.0.ebuild
+++ b/sci-mathematics/coq/coq-8.18.0.ebuild
@@ -17,7 +17,7 @@ S="${WORKDIR}"/${MY_P}
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug doc gui +ocamlopt test"
RESTRICT="!test? ( test )"