summaryrefslogtreecommitdiff
path: root/sci-physics/lhapdf/lhapdf-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/lhapdf/lhapdf-9999.ebuild')
-rw-r--r--sci-physics/lhapdf/lhapdf-9999.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/sci-physics/lhapdf/lhapdf-9999.ebuild b/sci-physics/lhapdf/lhapdf-9999.ebuild
index d6db5a753ed2..492a8fed8602 100644
--- a/sci-physics/lhapdf/lhapdf-9999.ebuild
+++ b/sci-physics/lhapdf/lhapdf-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DOCS_BUILDER="doxygen"
DOCS_DEPEND="
dev-texlive/texlive-bibtexextra
@@ -24,18 +24,27 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/hepcedar/lhapdf"
else
- SRC_URI="https://www.hepforge.org/downloads/lhapdf/${MY_PF}.tar.gz"
+ SRC_URI="https://www.hepforge.org/downloads/lhapdf/${MY_PF}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${MY_PF}"
- KEYWORDS="~amd64"
+ KEYWORDS="amd64"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="examples"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="examples +python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="${PYTHON_DEPS}"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.19[${PYTHON_USEDEP}]
+ ')
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
src_prepare() {
default
@@ -47,7 +56,7 @@ src_configure() {
CONFIG_SHELL="${EPREFIX}/bin/bash" \
econf \
--disable-static \
- --enable-python
+ $(use_enable python)
}
src_compile() {
@@ -63,7 +72,7 @@ src_install() {
use doc && dodoc -r doc/doxygen/.
use examples && dodoc examples/*.cc
- python_optimize
+ use python && python_optimize
find "${ED}" -name '*.la' -delete || die
}