summaryrefslogtreecommitdiff
path: root/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild')
-rw-r--r--sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild b/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
deleted file mode 100644
index 443459fb8cbe..000000000000
--- a/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit autotools eutils
-
-DEB_PATCH="${PN}_${PV}-7"
-DESCRIPTION="OpenGL interactive relativistic simulator"
-HOMEPAGE="http://lightspeed.sourceforge.net/"
-SRC_URI="
- mirror://sourceforge/${PN}/${P}.tar.gz
- mirror://sourceforge/${PN}/objects-1.tar.gz
- mirror://debian/pool/main/${PN:0:1}/${PN}/${DEB_PATCH}.diff.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-IUSE="nls truetype"
-LANGS="es"
-for i in ${LANGS}; do
- IUSE="${IUSE} l10n_${i}"
-done
-
-RDEPEND="
- media-libs/libpng
- media-libs/tiff
- virtual/opengl
- x11-libs/gtkglext
- x11-libs/gtkglarea:2
- x11-libs/gtk+:2
- x11-libs/libXmu
- truetype? ( media-libs/ftgl )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S2="${WORKDIR}/objects"
-
-src_prepare() {
- epatch "${WORKDIR}/${DEB_PATCH}.diff"
- epatch \
- "${FILESDIR}"/${P}-autoconf.patch \
- "${FILESDIR}"/${P}-libpng15.patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-gtk=2 \
- $(use_enable nls) \
- $(use_with truetype ftgl)
-}
-
-src_compile() {
- emake
- local i
- for i in ${LANGS}; do
- use l10n_${i} && emake ${i}.gmo
- done
-}
-
-src_install() {
- default
- newicon src/icon.xpm lightspeed.xpm
- make_desktop_entry ${PN} "Light Speed! Relativistic Simulator"
- newdoc debian/changelog ChangeLog.Debian
- cd ${S2}
- newdoc README objects-README
- insinto /usr/share/${PN}
- doins *.3ds *.lwo
-}
-
-pkg_postinst() {
- elog
- elog "Some 3d models have been placed in /usr/share/${PN}"
- elog "You can load them in Light Speed! from the File menu."
- elog
-}