summaryrefslogtreecommitdiff
path: root/sci-visualization/gnuplot/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/gnuplot/files')
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-5.2.6-caca.patch13
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-5.2.8-caca.patch33
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-5.4.0-caca.patch46
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-5.4.0-no-mouse.patch27
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-5.4.0-pkg-config.patch40
5 files changed, 146 insertions, 13 deletions
diff --git a/sci-visualization/gnuplot/files/gnuplot-5.2.6-caca.patch b/sci-visualization/gnuplot/files/gnuplot-5.2.6-caca.patch
deleted file mode 100644
index 4441e4b8c036..000000000000
--- a/sci-visualization/gnuplot/files/gnuplot-5.2.6-caca.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://bugs.gentoo.org/690014
-https://sourceforge.net/p/gnuplot/mailman/message/34342174/
-
---- gnuplot-5.2.6-orig/configure.ac
-+++ gnuplot-5.2.6/configure.ac
-@@ -1224,6 +1224,7 @@
- if test "${enable_qt_ok}" = yes \
- || test "${enable_wxwidgets_ok}" = yes \
- || test "$GGI_SUPPORT" = yes \
-+ || test "$with_caca" = yes \
- || test "$no_x" != yes; then
- enable_mouse=yes;
- fi
diff --git a/sci-visualization/gnuplot/files/gnuplot-5.2.8-caca.patch b/sci-visualization/gnuplot/files/gnuplot-5.2.8-caca.patch
new file mode 100644
index 000000000000..2ce464f04499
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-5.2.8-caca.patch
@@ -0,0 +1,33 @@
+Patch backported from branch-5-4-stable.
+https://bugs.gentoo.org/690014
+
+--- gnuplot-5.2.8-orig/term/caca.trm
++++ gnuplot-5.2.8/term/caca.trm
+@@ -1909,8 +1909,11 @@
+ CACA_result loop = CACA_loop;
+ caca_event_t ev;
+ const int event_mask =
+- CACA_EVENT_KEY_PRESS | CACA_EVENT_RESIZE | CACA_EVENT_QUIT |
+- CACA_EVENT_MOUSE_MOTION | CACA_EVENT_MOUSE_PRESS | CACA_EVENT_MOUSE_RELEASE;
++ CACA_EVENT_KEY_PRESS | CACA_EVENT_RESIZE | CACA_EVENT_QUIT
++#ifdef USE_MOUSE
++ | CACA_EVENT_MOUSE_MOTION | CACA_EVENT_MOUSE_PRESS | CACA_EVENT_MOUSE_RELEASE
++#endif
++ ;
+ static int mx = 0, my = 0; /* current mouse position */
+ static unsigned long last_event_time = 0;
+
+@@ -2577,11 +2580,13 @@
+ }
+ }
+
++#ifdef USE_MOUSE
+ if (changed) {
+ /* Replot only if something changed. */
+ CACA_zoom_or_replot = TRUE;
+ process_event(GE_replot, 0, 0, 0, 0, 0);
+ }
++#endif
+ }
+
+
diff --git a/sci-visualization/gnuplot/files/gnuplot-5.4.0-caca.patch b/sci-visualization/gnuplot/files/gnuplot-5.4.0-caca.patch
new file mode 100644
index 000000000000..f92ac93ab018
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-5.4.0-caca.patch
@@ -0,0 +1,46 @@
+From f76d96206a7251d62dbbd3879bf0ad6dfe1ec486 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ulrich=20M=C3=BCller?= <ulm@gentoo.org>
+Date: Sat, 7 Nov 2020 11:25:07 -0800
+Subject: [PATCH] Allow to build --with-caca but without mouse support
+
+EAM: slightly modified fix
+Bug #2351
+---
+ term/caca.trm | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/term/caca.trm b/term/caca.trm
+index cf7c0d7c6..58606e2d8 100644
+--- a/term/caca.trm
++++ b/term/caca.trm
+@@ -1913,8 +1913,11 @@ CACA_process_events(void)
+ CACA_result loop = CACA_loop;
+ caca_event_t ev;
+ const int event_mask =
+- CACA_EVENT_KEY_PRESS | CACA_EVENT_RESIZE | CACA_EVENT_QUIT |
+- CACA_EVENT_MOUSE_MOTION | CACA_EVENT_MOUSE_PRESS | CACA_EVENT_MOUSE_RELEASE;
++ CACA_EVENT_KEY_PRESS | CACA_EVENT_RESIZE | CACA_EVENT_QUIT
++#ifdef USE_MOUSE
++ | CACA_EVENT_MOUSE_MOTION | CACA_EVENT_MOUSE_PRESS | CACA_EVENT_MOUSE_RELEASE
++#endif
++ ;
+ static int mx = 0, my = 0; /* current mouse position */
+ static unsigned long last_event_time = 0;
+
+@@ -2579,11 +2582,13 @@ CACA_modify_plots(unsigned int operations, int plotno)
+ }
+ }
+
++#ifdef USE_MOUSE
+ if (changed) {
+ /* Replot only if something changed. */
+ CACA_zoom_or_replot = TRUE;
+ exec_event(GE_replot, 0, 0, 0, 0, 0);
+ }
++#endif
+ }
+
+
+--
+2.29.2
+
diff --git a/sci-visualization/gnuplot/files/gnuplot-5.4.0-no-mouse.patch b/sci-visualization/gnuplot/files/gnuplot-5.4.0-no-mouse.patch
new file mode 100644
index 000000000000..8133c3516edf
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-5.4.0-no-mouse.patch
@@ -0,0 +1,27 @@
+From cfd9ff9408949ee58be9ba5a18b74ce4562f374a Mon Sep 17 00:00:00 2001
+From: Ethan A Merritt <merritt@u.washington.edu>
+Date: Fri, 6 Nov 2020 13:06:21 -0800
+Subject: [PATCH] make sure warning message about no mouse support is non-fatal
+
+Bug #2350
+---
+ src/set.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/set.c b/src/set.c
+index a697925bc..a6acf8fc6 100644
+--- a/src/set.c
++++ b/src/set.c
+@@ -3130,7 +3130,8 @@ set_mouse()
+ PM_update_menu_items();
+ #endif
+ #else /* USE_MOUSE */
+- c_token++;
++ while (!END_OF_COMMAND)
++ c_token++;
+ int_warn(NO_CARET, "this copy of gnuplot has no mouse support");
+ #endif /* USE_MOUSE */
+ }
+--
+2.29.2
+
diff --git a/sci-visualization/gnuplot/files/gnuplot-5.4.0-pkg-config.patch b/sci-visualization/gnuplot/files/gnuplot-5.4.0-pkg-config.patch
new file mode 100644
index 000000000000..aa98f27dc2b2
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-5.4.0-pkg-config.patch
@@ -0,0 +1,40 @@
+From 87034e509b366078b746a3a70e05aaf497e34585 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ulrich=20M=C3=BCller?= <ulm@gentoo.org>
+Date: Fri, 6 Nov 2020 13:25:02 +0100
+Subject: [PATCH] configure.ac: move PKG_PROG_PKG_CONFIG to the beginning of
+ the file
+
+Bug #2349
+---
+ configure.ac | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 67ad1396c..606242ea3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -88,6 +88,10 @@ AC_CHECK_MEMBERS([struct tm.tm_gmtoff, struct tm.__tm_gmtoff],,,[
+ #include <sys/types.h>
+ #include <time.h>])
+
++dnl explicit call to PKG_PROG_PKG_CONFIG because the first call to
++dnl PKG_CHECK_MODULES{,_NOFAIL} may not happen
++PKG_PROG_PKG_CONFIG
++
+ AC_ARG_WITH(libcerf,dnl
+ [ --without-libcerf build without special functions from libcerf (default enabled)],,
+ [test -z "${with_libcerf}" && with_libcerf=yes])
+@@ -759,10 +763,6 @@ AC_ARG_ENABLE(raise-console,dnl
+ fi
+
+
+-dnl explicit call to PKG_PROG_PKG_CONFIG because the first call to
+-dnl PKG_CHECK_MODULES may not happen
+-PKG_PROG_PKG_CONFIG
+-
+ dnl wxWidgets terminal
+
+ dnl wxWidgets terminal needs C++
+--
+2.29.2
+