summaryrefslogtreecommitdiff
path: root/sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild')
-rw-r--r--sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild29
1 files changed, 7 insertions, 22 deletions
diff --git a/sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild b/sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild
index e5aae89a82c2..60eb7036ba0e 100644
--- a/sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-5.3.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,15 +9,11 @@ DESCRIPTION="Command-line driven interactive plotting program"
HOMEPAGE="http://www.gnuplot.info/"
if [[ -z ${PV%%*9999} ]]; then
- inherit cvs
- ECVS_SERVER="gnuplot.cvs.sourceforge.net:/cvsroot/gnuplot"
- ECVS_MODULE="gnuplot"
- ECVS_BRANCH="HEAD"
- ECVS_USER="anonymous"
- ECVS_CVS_OPTIONS="-dP"
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/gnuplot/gnuplot-main"
+ EGIT_BRANCH="master"
MY_P="${PN}"
- SRC_URI=""
- KEYWORDS=""
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${MY_P}"
else
MY_P="${P/_/.}"
SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
@@ -26,7 +22,7 @@ fi
LICENSE="gnuplot bitmap? ( free-noncomm )"
SLOT="0"
-IUSE="aqua bitmap cairo compat doc examples +gd ggi latex libcaca libcerf lua qt5 readline svga wxwidgets X"
+IUSE="aqua bitmap cairo doc examples +gd ggi latex libcaca libcerf lua qt5 readline wxwidgets X"
RDEPEND="
cairo? (
@@ -49,7 +45,6 @@ RDEPEND="
dev-qt/qtwidgets:5= )
readline? ( sys-libs/readline:0= )
libcerf? ( sci-libs/libcerf )
- svga? ( media-libs/svgalib )
wxwidgets? (
x11-libs/wxGTK:3.0[X]
x11-libs/cairo
@@ -89,10 +84,6 @@ src_prepare() {
DOC_CONTENTS='Gnuplot no longer links against pdflib, see the ChangeLog
for details. You can use the "pdfcairo" terminal for PDF output.'
use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
- use svga && DOC_CONTENTS+='\n\nIn order to enable ordinary users to use
- SVGA console graphics, gnuplot needs to be set up as setuid root.
- Please note that this is usually considered to be a security hazard.
- As root, manually "chmod u+s /usr/bin/gnuplot".'
use gd && DOC_CONTENTS+='\n\nFor font support in png/jpeg/gif output,
you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
environment variables. See the FAQ file in /usr/share/doc/${PF}/
@@ -116,7 +107,7 @@ src_configure() {
if use wxwidgets; then
WX_GTK_VER="3.0"
- need-wxwidgets unicode
+ setup-wxwidgets
fi
tc-export CC CXX #453174
@@ -130,7 +121,6 @@ src_configure() {
--with-readline=$(usex readline gnu builtin) \
$(use_with bitmap bitmap-terminals) \
$(use_with cairo) \
- $(use_enable compat backwards-compatibility) \
$(use_with doc tutorial) \
$(use_with gd) \
"$(use_with ggi ggi "${EPREFIX}/usr/$(get_libdir)")" \
@@ -138,7 +128,6 @@ src_configure() {
"$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
$(use_with libcerf) \
$(use_with lua) \
- $(use_with svga linux-vga) \
$(use_with X x) \
--enable-stats \
$(use_with qt5 qt qt5) \
@@ -151,10 +140,6 @@ src_compile() {
# Prevent access violations, see bug 201871
export VARTEXFONTS="${T}/fonts"
- # We believe that the following line is no longer needed.
- # In case of problems file a bug report at bugs.gentoo.org.
- #addwrite /dev/svga:/dev/mouse:/dev/tts/0
-
emake all
if use doc; then