summaryrefslogtreecommitdiff
path: root/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/baselayout-prefix/baselayout-prefix-2.2-r5.ebuild')
-rw-r--r--sys-apps/baselayout-prefix/baselayout-prefix-2.2-r5.ebuild28
1 files changed, 5 insertions, 23 deletions
diff --git a/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r5.ebuild b/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r5.ebuild
index 598159ce7569..5eb365ee62ad 100644
--- a/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r5.ebuild
+++ b/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,22 +27,6 @@ pkg_preinst() {
rm -f "${EROOT}"/etc/._cfg????_gentoo-release
}
-src_prepare() {
- if use prefix-chain; then
- eapply "${FILESDIR}"/baselayout-${PV}-prefix-chaining.patch
-
- # need to set the PKG_CONFIG_PATH globally for this prefix, when
- # chaining is enabled, since pkg-config may not be installed locally,
- # but still .pc files should be found for all RDEPENDable prefixes in
- # the chain.
- echo "PKG_CONFIG_PATH=\"/usr/lib/pkgconfig:/usr/share/pkgconfig\"" >> etc/env.d/00basic
- echo "PORTAGE_OVERRIDE_EPREFIX=\"${EPREFIX}\"" >> etc/env.d/00basic
- echo "PORTAGE_CONFIGROOT=\"${EPREFIX}\"" >> etc/env.d/00basic
- echo "EPREFIX=\"${EPREFIX}\"" >> etc/env.d/00basic
- fi
- default
-}
-
src_install() {
# make functions.sh available in /etc/init.d (from gentoo-functions)
# Note: we cannot replace the symlink with a file here, or Portage will
@@ -55,12 +39,10 @@ src_install() {
-e "/PATH=/!s:/\(etc\|usr/bin\|bin\):\"${EPREFIX}\"/\1:g" \
-e "/PATH=/s|\([:\"]\)/|\1${EPREFIX}/|g" \
etc/profile > "${ED}"/etc/profile || die
- if ! use prefix-chain; then
- sed \
- -e "/PATH=.*\/sbin/s|\"$|:/usr/sbin:/sbin\"|" \
- -e "/PATH=.*\/bin/s|\"$|:/usr/bin:/bin\"|" \
- -i "${ED}"/etc/profile || die
- fi
+ sed \
+ -e "/PATH=.*\/sbin/s|\"$|:/usr/sbin:/sbin\"|" \
+ -e "/PATH=.*\/bin/s|\"$|:/usr/bin:/bin\"|" \
+ -i "${ED}"/etc/profile || die
dodir etc/env.d
sed \
-e "s:/\(etc/env.d\|opt\|usr\):${EPREFIX}/\1:g" \