summaryrefslogtreecommitdiff
path: root/sys-apps/bubblewrap
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/bubblewrap')
-rw-r--r--sys-apps/bubblewrap/Manifest4
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.10.0.ebuild58
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.9.0.ebuild58
3 files changed, 120 insertions, 0 deletions
diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
index 56e4c5bae4f8..ddedf542e441 100644
--- a/sys-apps/bubblewrap/Manifest
+++ b/sys-apps/bubblewrap/Manifest
@@ -1,3 +1,7 @@
+DIST bubblewrap-0.10.0.tar.xz 119328 BLAKE2B 2b4b08409612e08c1ee7cde1dabb422cdc3e994f12ad8df94c99ad15c6355e605f73159df6ea32a54a7cf219e72c55a8ad72a73c3138f06b375fca36eff0c53e SHA512 d9e60c1999f8e205d4126cbc0680f6ee6cd316a461ad81563bc0aa606f3b257da5f36d4934b13d6ab1745aa78946224223455d44edff41d16238e8633f0eced9
DIST bubblewrap-0.8.0.tar.xz 149088 BLAKE2B 5853cf42a7ab653540ec5134866c6f2459aa101e9eea724a4f283405cbcae2beb3551b7c1a7aa93d82016d4eb0d12f9c97c47df53a6d9b589db40483696253de SHA512 1cbc33f3c834ff83f4c1808d3ec2555921277d495f903ad152cbd5065a6e100c5420b4b5c62386bb2d303eb1734e074b09625013e55e3bd8631cfb3582d70e1c
+DIST bubblewrap-0.9.0.tar.xz 118984 BLAKE2B 52a4e87e502da44a25031b6d6044da7712dccb2c58a2debad9a8562fd1e48805d783bec571adc0df8880a63595825a4204ceaaa4f3df2672252c631f7fe5b0c7 SHA512 3a3af355e4fdb19a91c40020d68fd83f7c74ebef92d989c932933293758bc0175fa41220c47fe829b84ba29457a12f0e225c19afe674ecbf983b0826dbc1c878
+EBUILD bubblewrap-0.10.0.ebuild 1164 BLAKE2B 4fb26371633169e369ca97d110b396194071f098e07fb81473b1a584af608cda03fb2dfa751e3a4b854d0e98619cf050e96a50b4ccf441ee1546d5eaa2707117 SHA512 a7fc16d2ff33b14dd634782dd558c49cb62d624c4514e3b410e4f79f4da4e6a83ac76387d44dd255db2c63e83fe0e8f794ee5fccd85d9139e045b9698a6bd50c
EBUILD bubblewrap-0.8.0.ebuild 1158 BLAKE2B f2c3dff4784e903111870d3e813366630aafb7f917bde0d2f2ae0a662016eb2ed8939376432992052de7b3d26de462ebffbaa607d6ee1da828bed59a8dd55552 SHA512 26230393ca0bc79ff576cac7194a6f407157bf50ecefb6d2003646dcba21c4c13b82c6ea21681af3ae204a614fa19e0b28199491955dd0a213fa3c3f103709dc
+EBUILD bubblewrap-0.9.0.ebuild 1164 BLAKE2B 4fb26371633169e369ca97d110b396194071f098e07fb81473b1a584af608cda03fb2dfa751e3a4b854d0e98619cf050e96a50b4ccf441ee1546d5eaa2707117 SHA512 a7fc16d2ff33b14dd634782dd558c49cb62d624c4514e3b410e4f79f4da4e6a83ac76387d44dd255db2c63e83fe0e8f794ee5fccd85d9139e045b9698a6bd50c
MISC metadata.xml 340 BLAKE2B f082c9eef68d5f1bc96a25712769cf2625595ddf23de0c6c5c51b57e03d75cb795fce47bf6df009309158e275db9d709278ac3d010d8b09009d591486e817118 SHA512 76d774e9c5df0184246aecbb1c2697cf7e2a5c580194c2a826498169b3972925f4bb25bae10bd438a8f404e46f74af59c91eb39b8ec2a5ff71b5ad01ffa46e90
diff --git a/sys-apps/bubblewrap/bubblewrap-0.10.0.ebuild b/sys-apps/bubblewrap/bubblewrap-0.10.0.ebuild
new file mode 100644
index 000000000000..f52fb2cc4958
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.10.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/containers/bubblewrap/"
+SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="selinux suid"
+
+RDEPEND="
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# tests require root privileges
+RESTRICT="test"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dbash_completion=enabled
+ -Dman=enabled
+ -Dtests=false
+ -Dzsh_completion=enabled
+ $(meson_feature selinux)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use suid; then
+ chmod u+s "${ED}"/usr/bin/bwrap
+ fi
+}
diff --git a/sys-apps/bubblewrap/bubblewrap-0.9.0.ebuild b/sys-apps/bubblewrap/bubblewrap-0.9.0.ebuild
new file mode 100644
index 000000000000..f52fb2cc4958
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.9.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/containers/bubblewrap/"
+SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="selinux suid"
+
+RDEPEND="
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# tests require root privileges
+RESTRICT="test"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dbash_completion=enabled
+ -Dman=enabled
+ -Dtests=false
+ -Dzsh_completion=enabled
+ $(meson_feature selinux)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use suid; then
+ chmod u+s "${ED}"/usr/bin/bwrap
+ fi
+}