summaryrefslogtreecommitdiff
path: root/sys-apps/firejail/firejail-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/firejail/firejail-9999.ebuild')
-rw-r--r--sys-apps/firejail/firejail-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-apps/firejail/firejail-9999.ebuild b/sys-apps/firejail/firejail-9999.ebuild
index e3bf15c00bbd..440d20af51ec 100644
--- a/sys-apps/firejail/firejail-9999.ebuild
+++ b/sys-apps/firejail/firejail-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit toolchain-funcs python-single-r1 linux-info
@@ -21,7 +21,7 @@ HOMEPAGE="https://firejail.wordpress.com/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="apparmor +chroot contrib +dbusproxy +file-transfer +globalcfg +network +private-home +suid test +userns +whitelist X"
+IUSE="apparmor +chroot contrib +dbusproxy +file-transfer +globalcfg +network +private-home test +userns +whitelist X"
# Needs a lot of work to function within sandbox/portage
# bug #769731
RESTRICT="test"
@@ -68,6 +68,7 @@ src_prepare() {
src_configure() {
econf \
--disable-firetunnel \
+ --enable-suid \
$(use_enable apparmor) \
$(use_enable chroot) \
$(use_enable dbusproxy) \
@@ -75,7 +76,6 @@ src_configure() {
$(use_enable globalcfg) \
$(use_enable network) \
$(use_enable private-home) \
- $(use_enable suid) \
$(use_enable userns) \
$(use_enable whitelist) \
$(use_enable X x11)