summaryrefslogtreecommitdiff
path: root/sys-apps/grep
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/Manifest1
-rw-r--r--sys-apps/grep/grep-3.11.ebuild115
2 files changed, 0 insertions, 116 deletions
diff --git a/sys-apps/grep/Manifest b/sys-apps/grep/Manifest
index f0923a61e787..ea4c48383f6f 100644
--- a/sys-apps/grep/Manifest
+++ b/sys-apps/grep/Manifest
@@ -2,5 +2,4 @@ AUX grep-3.11-100k-files-dir.patch 4488 BLAKE2B 54d97710fbfe400980cd2fa7385fb7b1
DIST grep-3.11.tar.xz 1703776 BLAKE2B e21785bca20b5a090d32bb5dc525fb298af30165106ed4c289b1518ea3d2acdcacfd6309b12f13be29a4b958f19588546119c695deb2b7500d49dcff86357bdc SHA512 f254a1905a08c8173e12fbdd4fd8baed9a200217fba9d7641f0d78e4e002c1f2a621152d67027d9b25f0bb2430898f5233dc70909d8464fd13d7dd9298e65c42
DIST grep-3.11.tar.xz.sig 833 BLAKE2B 5edfba20e3a9f54d25ae63cf04985382bf6afb0ca643979561321090614e68b5d234767b07e48211888722c52c441233093735e183ff69432d5ee2e6a4f53aea SHA512 487aba063373ca0594c519991f19b2a6a33b3da0d74735c890f3828fd0880e7e6f64495d2c8f9efa5da53d1eb2d446609bab2399a4b89dcb4510a632e31ffb54
EBUILD grep-3.11-r1.ebuild 3162 BLAKE2B ff70bbb04cae95934902af53b885027adb712e9247e49da3d236261f2a858d6e9df6ab61b05b335030f332dbe80b600498d35f17cda0a4eeb81ff6d3d1be088a SHA512 2afdfb5de11219f9800b9977bea11fe1ca55df6c8641471790373884ed2c5af690dc65feb82c511480d7e3be76a033b7fa4dc45bdc2298020350df733530c37b
-EBUILD grep-3.11.ebuild 2959 BLAKE2B 15f6327017af31f552a6f4138b1c12ee7bd6b44e302280fc330425544615e08131da04b1a671a332a0a9196fff24095a73bb09cb6a83a861fff7f871c939b45a SHA512 6406057f0194dc602b17f36c381cdf2b29a0e6aadbcc09bf96437653cf5c95c33bb110597c0777f4a55e064d15662e9f6b220455832bc8d1346e41655c90b3a7
MISC metadata.xml 712 BLAKE2B 9cc40dc17c2f903378eba194b71412eca93b013576e23f8deafbce55262b52ec799d11612856d30c91c4fddd51236f4c1a670c39ed0b38b2751dcd9c456cbb9f SHA512 46734c74422d8dfe79bbf635d34e200db3b884be830bf275cb95ac0dea5fc2ada7d2745dff1d535efbf6cc4277381347d13f3f2551a2901a6fcdbf598151953b
diff --git a/sys-apps/grep/grep-3.11.ebuild b/sys-apps/grep/grep-3.11.ebuild
deleted file mode 100644
index d5a615b66275..000000000000
--- a/sys-apps/grep/grep-3.11.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/grep.asc
-inherit flag-o-matic verify-sig
-
-DESCRIPTION="GNU regular expression matcher"
-HOMEPAGE="https://www.gnu.org/software/grep/"
-
-if [[ ${PV} == *_p* ]] ; then
- # Subscribe to the 'platform-testers' ML to find these.
- # Useful to test on our especially more niche arches and report issues upstream.
- MY_COMMIT="19-2ea9"
- MY_P=${PN}-$(ver_cut 1-2).${MY_COMMIT}
- SRC_URI="https://meyering.net/${PN}/${MY_P}.tar.xz"
- SRC_URI+=" verify-sig? ( https://meyering.net/${PN}/${MY_P}.tar.xz.sig )"
- S="${WORKDIR}"/${MY_P}
-else
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
- SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="+egrep-fgrep nls pcre static"
-
-# We lack dev-libs/libsigsegv[static-libs] for now
-REQUIRED_USE="static? ( !sparc )"
-
-LIB_DEPEND="
- pcre? ( >=dev-libs/libpcre2-10.42-r1[static-libs(+)] )
- sparc? ( dev-libs/libsigsegv )
-"
-RDEPEND="
- !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
- nls? ( virtual/libintl )
- virtual/libiconv
-"
-DEPEND="
- ${RDEPEND}
- static? ( ${LIB_DEPEND} )
-"
-BDEPEND="
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- verify-sig? ( sec-keys/openpgp-keys-grep )
-"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
-
-QA_CONFIG_IMPL_DECL_SKIP=(
- # Either gnulib FPs or fixed in newer autoconf, not worth autoreconf here for now?
- MIN
- alignof
- static_assert
-)
-
-src_prepare() {
- default
-
- # bug #523898
- sed -i \
- -e "s:@SHELL@:${EPREFIX}/bin/sh:g" \
- -e "s:@grep@:${EPREFIX}/bin/grep:" \
- src/egrep.sh || die
-}
-
-src_configure() {
- use static && append-ldflags -static
-
- # We used to turn this off unconditionally (bug #673524) but we now
- # allow it for cases where libsigsegv is better for userspace handling
- # of stack overflows.
- # In particular, it's necessary for sparc: bug #768135
- export ac_cv_libsigsegv=$(usex sparc)
-
- local myeconfargs=(
- --bindir="${EPREFIX}"/bin
- $(use_enable nls)
- $(use_enable pcre perl-regexp)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- if use egrep-fgrep ; then
- # Delete the upstream wrapper variants which warn on egrep+fgrep use
- rm "${ED}"/bin/{egrep,fgrep} || die
-
- into /
- # Install egrep, fgrep which don't warn.
- #
- # We do this by default to avoid breakage in old scripts
- # and such which don't expect unexpected output on stderr,
- # we've had examples of builds failing because foo-config
- # starts returning a warning.
- #
- # https://lists.gnu.org/archive/html/bug-grep/2022-10/msg00000.html
- newbin - egrep <<-EOF
- #!/usr/bin/env sh
- exec "${EPREFIX}/bin/grep" -E "\$@"
- EOF
-
- newbin - fgrep <<-EOF
- #!/usr/bin/env sh
- exec "${EPREFIX}/bin/grep" -F "\$@"
- EOF
- fi
-}