summaryrefslogtreecommitdiff
path: root/sys-apps/habitat/habitat-0.28.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/habitat/habitat-0.28.0.ebuild')
-rw-r--r--sys-apps/habitat/habitat-0.28.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/habitat/habitat-0.28.0.ebuild b/sys-apps/habitat/habitat-0.28.0.ebuild
new file mode 100644
index 000000000000..c968a4910847
--- /dev/null
+++ b/sys-apps/habitat/habitat-0.28.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Application automation framework"
+HOMEPAGE="https://github.com/habitat-sh/habitat https://habitat.sh"
+SRC_URI="https://github.com/habitat-sh/habitat/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~mrueg/files/${PN}-cargo-${PV}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-util/cargo
+ >=dev-lang/rust-1.11
+ >=net-libs/zeromq-3.2
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ # move cache dir where cargo expects it
+ mv ../.cargo "${HOME}" || die
+}
+
+src_install() {
+ dodoc README.md CHANGELOG.md
+ dobin target/debug/hab{,-butterfly,-sup}
+}
+
+src_test() {
+ emake unit-all
+}