summaryrefslogtreecommitdiff
path: root/sys-apps/msr-tools/msr-tools-1.3_p20170320.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/msr-tools/msr-tools-1.3_p20170320.ebuild')
-rw-r--r--sys-apps/msr-tools/msr-tools-1.3_p20170320.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/msr-tools/msr-tools-1.3_p20170320.ebuild b/sys-apps/msr-tools/msr-tools-1.3_p20170320.ebuild
new file mode 100644
index 000000000000..ecb5ab4f9683
--- /dev/null
+++ b/sys-apps/msr-tools/msr-tools-1.3_p20170320.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CONFIG_CHECK="~X86_CPUID ~X86_MSR"
+inherit autotools linux-info
+
+EGIT_COMMIT="eec71d977a83f8dc76bc3ccc6de5cbd3be378572"
+
+DESCRIPTION="Utilities allowing the read and write of CPU model-specific registers (MSR)"
+HOMEPAGE="https://github.com/intel/msr-tools"
+SRC_URI="https://github.com/intel/msr-tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ einfo "Be sure that before using msr-tools utilities Linux kernel modules"
+ einfo "cpuid.ko and msr.ko are loaded."
+}