summaryrefslogtreecommitdiff
path: root/sys-apps/osinfo-db
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/osinfo-db')
-rw-r--r--sys-apps/osinfo-db/Manifest2
-rw-r--r--sys-apps/osinfo-db/osinfo-db-20200325.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db/Manifest b/sys-apps/osinfo-db/Manifest
index 5b4665cdc510..58cfdb21f543 100644
--- a/sys-apps/osinfo-db/Manifest
+++ b/sys-apps/osinfo-db/Manifest
@@ -1,3 +1,5 @@
DIST osinfo-db-20200214.tar.xz 99572 BLAKE2B 0342b35c5e370d98a23ccc36c72233ac2d92d11d30330b6188101cd9451e7c557849c3d1d65c0d469d6539c5b4347a4fc16eb7a5a92493bd5a2a887fb19ade08 SHA512 b51f62f2d31b4da9cc6162b3798cdef0993b7cea2c884cbeffb4e81de027bbd077ab1c3d871391e456b41e87bf2a3e80244c01a49f39db53285cca0596ec09b4
+DIST osinfo-db-20200325.tar.xz 100124 BLAKE2B 89bc55dc4af0943abc59bdf0cbba070bb133129900269477dbb598e623b41b313cc41283d5e22c6a3277a7cf420baf294bf275c2c3e6f11ca98451c0ffa5b16b SHA512 c192a3814063f60d7ece0b912035e15d98c8363ff10e5c5ea5aae97ab10d95b85c5837c496f3dc4a26d3626df06559960b138986d9f4727b3d0477015e29cfa0
EBUILD osinfo-db-20200214.ebuild 668 BLAKE2B 5bd9f45c5745d97052e35df92fd9a6d7dd413816f28112c7574f310e792e905ab0b64f8198e968435d9c48c2d3b599edd0a9bf220be99f073ce7669042e9c79b SHA512 27ba85e90d6ec6079ef998b26cf86263345944644b93d86411e029ad8366b3e4570e349abe7579c27c31e5b4200f1b5885ce6dd9ccb7dc46701590b35571990e
+EBUILD osinfo-db-20200325.ebuild 671 BLAKE2B 1a1edab17c338bbc4067cbf99b89e362307a142f5c53c2ad2dd72bec89b88a13843b66a0552156bc1c7d3437641cefd767d6c3877d93cd7216fadc2b1c3c3da7 SHA512 a46832e3fbb2f8e5eb6632632896faeb184da58a01a1297fcfee5151b6235578a13ae413a2a48031399da2be31f050607cf7d71c32a65fbc944eb9d45d14a04a
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/sys-apps/osinfo-db/osinfo-db-20200325.ebuild b/sys-apps/osinfo-db/osinfo-db-20200325.ebuild
new file mode 100644
index 000000000000..ee488fdf635f
--- /dev/null
+++ b/sys-apps/osinfo-db/osinfo-db-20200325.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="osinfo database files"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-apps/osinfo-db-tools
+"
+# we don't depend on intltool here, contrary to README, as the tarball already
+# contains the processed results with translations in XML files
+
+src_unpack() { :; }
+
+src_install() {
+ osinfo-db-import --root "${D}" --dir "/usr/share/osinfo" "${DISTDIR}/${A}"
+}