summaryrefslogtreecommitdiff
path: root/sys-apps/osinfo-db
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/osinfo-db')
-rw-r--r--sys-apps/osinfo-db/Manifest2
-rw-r--r--sys-apps/osinfo-db/osinfo-db-20240523.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db/Manifest b/sys-apps/osinfo-db/Manifest
index 9fa62c4d1678..2709a5655cb2 100644
--- a/sys-apps/osinfo-db/Manifest
+++ b/sys-apps/osinfo-db/Manifest
@@ -1,3 +1,5 @@
DIST osinfo-db-20231215.tar.xz 149836 BLAKE2B bbc4cabbb2ef09dd58f0340c250ac9d014dbb7f38e7db96ecdb70bc4f7a6583f4a6c807262a52c5ada0eed7e69888b34bcf09a0041a943d0a3867ab9518e9005 SHA512 fed7b1fc28aa625a73242768776c451fc459bbbba71dcda33194e9e0d8d049cdfdfcc354ca4289e1a97f82b23d4ec3a105e23d18438789fe1fe64e7bbb84a6b7
+DIST osinfo-db-20240523.tar.xz 151604 BLAKE2B 252a0acd6996681dd338abd70d831f1b99fef5b45fac4da167be11846fbb2dc3d8996881017c56506ca1fbe5320c54ad5eca39dc21558652a51e4d41009346c2 SHA512 6ad1927e86ece97d3acb8a0c46d7cb0d7a3ecd1ad7af17900eb8bc6927cd42e662c7473e2a0f2b6e4f8a5179b139dcbd969a234d42bf76c8f9b37c8adf50cf00
EBUILD osinfo-db-20231215.ebuild 698 BLAKE2B 3be6e49cb82e52262006eb041ddf3ca084a46cc8e7189acb4746cd38e19dcaa033cdb3d170edd31627e510da793cc0ff2af5a4e549f1864a3b2e40a731523fe0 SHA512 f10f94eb213fb256656abf268339d75713752dad50a9be64032b3d63f082d7850af7fb93d43303bbd0ffbb029d448523fe094a07d40bb617c3d95c62e01823a5
+EBUILD osinfo-db-20240523.ebuild 702 BLAKE2B aed80acb9e0fc6ff63169d46fe5638896690fcd71079c1dbb34dea39ed3560d960a234b6f8d592ff92ba0368bc421e478c3719eb041bea2ddbfd070d5fc8ee62 SHA512 2a0ac89589cda2a2432a02110e8bb7361f52f0ba668c724027136c83f7fe6dc94d3715112fc2ea85f9fd842a08dcb59def59bbaa371fc240216e80fa88378af2
MISC metadata.xml 373 BLAKE2B 76c02900ad2c6c313bcc5f3806b1e9911ec01f23c057847bbbdb70ff7de957541d131fe6f57ab74473d20389c1562b1938fd2248ab70747fae68fa664fce2a28 SHA512 6759db491e7ce75a4a0b9805b8ff7e2bd1800fc626560e47af4e14de6ca4632e7dfc9fe7fe7ae1da8ca5b56b94854a92c5057bda98601e134012e63ff9c756a5
diff --git a/sys-apps/osinfo-db/osinfo-db-20240523.ebuild b/sys-apps/osinfo-db/osinfo-db-20240523.ebuild
new file mode 100644
index 000000000000..7e40fd5536dc
--- /dev/null
+++ b/sys-apps/osinfo-db/osinfo-db-20240523.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="osinfo database files"
+HOMEPAGE="https://libosinfo.org/ https://gitlab.com/libosinfo/osinfo-db"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="sys-apps/osinfo-db-tools"
+
+# we don't depend on intltool here, contrary to README, as the tarball already
+# contains the processed results with translations in XML files
+
+src_unpack() { :; }
+
+src_install() {
+ osinfo-db-import --root "${D}" --dir "/usr/share/osinfo" "${DISTDIR}/${A}"
+}