summaryrefslogtreecommitdiff
path: root/sys-apps/pkgcore/pkgcore-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pkgcore/pkgcore-9999.ebuild')
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index 2998f6377a3f..d98868c1bf84 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -24,7 +24,7 @@ RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
if [[ ${PV} == *9999 ]]; then
RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND+=" >=dev-python/snakeoil-0.9.0[${PYTHON_USEDEP}]"
+ RDEPEND+=" >=dev-python/snakeoil-0.9.3[${PYTHON_USEDEP}]"
fi
BDEPEND="
test? (
@@ -35,6 +35,11 @@ BDEPEND="
distutils_enable_tests setup.py
+src_test() {
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
python_install_all() {
local DOCS=( NEWS.rst )
[[ ${PV} == *9999 ]] || doman man/*