summaryrefslogtreecommitdiff
path: root/sys-apps/restartd
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/restartd')
-rw-r--r--sys-apps/restartd/Manifest3
-rw-r--r--sys-apps/restartd/files/restartd-0.2.2-fno-common.patch66
-rw-r--r--sys-apps/restartd/restartd-0.2.2-r1.ebuild5
3 files changed, 71 insertions, 3 deletions
diff --git a/sys-apps/restartd/Manifest b/sys-apps/restartd/Manifest
index 4c865f051a62..a04f5da7c746 100644
--- a/sys-apps/restartd/Manifest
+++ b/sys-apps/restartd/Manifest
@@ -1,3 +1,4 @@
+AUX restartd-0.2.2-fno-common.patch 1433 BLAKE2B 0e63b4ca36108331c249891c6fc45ae2d3605e6779973900135143e2307438fb78d64976a9a8be74fd387da5112297fc1ff1b3584d9a7139cbcd507c85327a1e SHA512 a1b5b60311e4e7a8a840a052b916a1af6cdcb20fde298886d42c313812049bda5e7c8ebd8e931c8e873441ea7dc2a41ad4de9fbf031e31043f167ed84a55f297
DIST restartd_0.2.2.tar.gz 13777 BLAKE2B ccefeb3b6b8e7a288d52793a708a1158804530c3ac8351c9b40b33ce2ff725511c8ce19558f3100dc5f01a4d9f6b17252362d97979c2a7d54dbe71392593b070 SHA512 731d33e6ade389708801e6cb024c355062745d049ab389fc78fcc1918720c93601dc8fb3a56a8bbb626bffc0a240b16e33ff5a8614d27b2701eb6ca68018cc93
-EBUILD restartd-0.2.2-r1.ebuild 683 BLAKE2B 64c92becfc4b55cb598786ed94d1c2cb7798f2a63a1251b7ed942a550a5d64586614b1172af9dadd6143dbd1b793b4a5353b4cf682d6a74e6ffe87c9865c382b SHA512 f76698fa08444badbc49f9a08c5d70fbf6349bdf714ee46d8805eca66c7ca6bc1b848956e5ea0a2b696ab83cfd787aa08c08902cf2151eae955346cb509b270a
+EBUILD restartd-0.2.2-r1.ebuild 721 BLAKE2B bd1894497e2b5544ea8020559567081f28fd5ecb9743514add72f5d7c98288ec3c17dc186055a4cb34c4d0b353c2e12b4c830bbeb94328ce654756f9052c177e SHA512 77a4c94964c7a6e63709526087ac382e065e33a0e10ba004de97d32b0be1f64cfd07fd80574918385da73cf7323c786df82220539392c2e77c825ca6467a1d06
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/sys-apps/restartd/files/restartd-0.2.2-fno-common.patch b/sys-apps/restartd/files/restartd-0.2.2-fno-common.patch
new file mode 100644
index 000000000000..c0b0ad5ff8b1
--- /dev/null
+++ b/sys-apps/restartd/files/restartd-0.2.2-fno-common.patch
@@ -0,0 +1,66 @@
+--- a/config.c
++++ b/config.c
+@@ -22,6 +22,14 @@
+ #include <syslog.h>
+ #include "config.h"
+
++int debug;
++int config_process_number;
++int check_interval;
++int foreground;
++char *config_file;
++struct config_process_type *config_process;
++struct config_process_type config_process_type;
++
+ int
+ read_config (void)
+ {
+--- a/config.h
++++ b/config.h
+@@ -34,12 +34,12 @@
+ #define DEFAULT_CONFIG "/etc/restartd.conf"
+ #define VERSION "0.2.1"
+
+-int debug; // Debug
+-int config_process_number;
+-int check_interval;
+-int foreground;
+-struct config_process_type *config_process;
+-char *config_file;
++extern int debug; // Debug
++extern int config_process_number;
++extern int check_interval;
++extern int foreground;
++extern struct config_process_type *config_process;
++extern char *config_file;
+
+ typedef struct config_process_type
+ {
+@@ -51,7 +51,9 @@ typedef struct config_process_type
+ char processes[256];
+ char status[32];
+
+-} config_process_type;
++};
++
++extern struct config_process_type config_process_type;
+
+ int read_config ( /* char *config_file */ );
+
+--- a/main.c
++++ b/main.c
+@@ -35,6 +35,14 @@
+
+ #include "config.h"
+
++extern int debug;
++extern int config_process_number;
++extern int check_interval;
++extern int foreground;
++extern char *config_file;
++extern struct config_process_type *config_process;
++extern struct config_process_type config_process_type;
++
+ // SIGTERM & SIGHUP handler
+ void
+ got_signal (int sig)
diff --git a/sys-apps/restartd/restartd-0.2.2-r1.ebuild b/sys-apps/restartd/restartd-0.2.2-r1.ebuild
index dadb97c5f33b..6f78d10eb3a3 100644
--- a/sys-apps/restartd/restartd-0.2.2-r1.ebuild
+++ b/sys-apps/restartd/restartd-0.2.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,8 @@ SRC_URI="mirror://debian/pool/main/r/restartd/${PN}_${MY_PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_prepare() {
default