summaryrefslogtreecommitdiff
path: root/sys-apps/sed/sed-4.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sed/sed-4.2.2.ebuild')
-rw-r--r--sys-apps/sed/sed-4.2.2.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-apps/sed/sed-4.2.2.ebuild b/sys-apps/sed/sed-4.2.2.ebuild
index ad3f071a2b1b..b6da5a256ce2 100644
--- a/sys-apps/sed/sed-4.2.2.ebuild
+++ b/sys-apps/sed/sed-4.2.2.ebuild
@@ -22,13 +22,11 @@ DEPEND="${RDEPEND}
src_bootstrap_sed() {
# make sure system-sed works #40786
- export NO_SYS_SED=""
if ! type -p sed > /dev/null ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed "${T}"/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
- make clean || die "couldnt clean"
+ mkdir -p "${T}/bootstrap"
+ printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
+ chmod a+rx "${T}/bootstrap/sed"
+ PATH="${T}/bootstrap:${PATH}"
fi
}