summaryrefslogtreecommitdiff
path: root/sys-apps/sed/sed-4.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sed/sed-4.4-r1.ebuild')
-rw-r--r--sys-apps/sed/sed-4.4-r1.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/sys-apps/sed/sed-4.4-r1.ebuild b/sys-apps/sed/sed-4.4-r1.ebuild
index 26c3858da53b..39c3d130eacf 100644
--- a/sys-apps/sed/sed-4.4-r1.ebuild
+++ b/sys-apps/sed/sed-4.4-r1.ebuild
@@ -21,14 +21,12 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_bootstrap_sed() {
- # make sure system-sed works #40786
- export NO_SYS_SED=""
- if ! type -p sed > /dev/null ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed "${T}"/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
- emake clean
+ # make sure system-sed works #40786 #650052
+ if ! type -p sed > /dev/null || has_version 'sys-apps/sed[forced-sandbox]' ; then
+ mkdir -p "${T}/bootstrap"
+ printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
+ chmod a+rx "${T}/bootstrap/sed"
+ PATH="${T}/bootstrap:${PATH}"
fi
}