summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild')
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
index 2ae2d2c52cae..e8fef5501652 100644
--- a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="doc geolocation"
+IUSE="doc geolocation screencast"
BDEPEND="
dev-util/gdbus-codegen
@@ -25,17 +25,19 @@ BDEPEND="
"
DEPEND="
dev-libs/glib:2[dbus]
+ dev-libs/json-glib
sys-fs/fuse:0
geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( media-video/pipewire )
"
RDEPEND="${DEPEND}"
src_configure() {
local myeconfargs=(
- --disable-pipewire
--with-systemduserunitdir="$(systemd_get_userunitdir)"
$(use_enable doc docbook-docs)
$(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
)
econf "${myeconfargs[@]}"
}