summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin51556 -> 51557 bytes
-rw-r--r--sys-apps/acl/Manifest1
-rw-r--r--sys-apps/acl/acl-2.3.2-r2.ebuild52
-rw-r--r--sys-apps/ipmiutil/Manifest2
-rw-r--r--sys-apps/ipmiutil/ipmiutil-3.2.1.ebuild86
5 files changed, 141 insertions, 0 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index ce985e99f754..c986f3b88f71 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/acl/Manifest b/sys-apps/acl/Manifest
index 4b48d5bee93c..748aca838e01 100644
--- a/sys-apps/acl/Manifest
+++ b/sys-apps/acl/Manifest
@@ -3,4 +3,5 @@ DIST acl-2.3.1.tar.xz 355676 BLAKE2B 15e81e8159ddb21ef0c262bef3101c0b6fa546738a2
DIST acl-2.3.2.tar.xz 371680 BLAKE2B 9f2abfddcd403df2c716c05f02a1b52453613d10948dc58a65b9ef41b44e37db6de99fb22dcfc4f6f0fb5d0319c939da61bd4e0fba2cdb5643e8087ecd34eeac SHA512 c2d061dbfd28c00cecbc1ae614d67f3138202bf4d39b383f2df4c6a8b10b830f33acec620fb211f268478737dde4037d338a5823af445253cb088c48a135099b
EBUILD acl-2.3.1-r2.ebuild 1945 BLAKE2B 61a48f7316cc5e4e44aebf85ebfcf5712c37f5bee83bd286cc0a2e45a448ca6cee1bfcd5830fbf83913d8e3aa0fabfbcb8833566929beed0c0aa1919b9d8c168 SHA512 3b1369ffe3c1911589e23479f2680181948675ccb7d545a691119a1a3120fe61688ba5897a15c6401cc89724c0b0942b5e5ae0015674a0180fca69fa9ecd0bc0
EBUILD acl-2.3.2-r1.ebuild 1264 BLAKE2B c1740b78311792604e4d1ca1a17c3d8ce278a29f2b7c0e9340a19ac15e4c41011282a812ef286ef529af3b218b518d7ceb98fbccf50e50773450cb3979090e0f SHA512 be696896a35b7d201f4c17b6d65b0d71837e81666acc830a2be3d9b0ec04bf509168e5d83ee77ec00a6bf08bc270b4354a452fc61a0ccac7bcce52a41dcb99c9
+EBUILD acl-2.3.2-r2.ebuild 1167 BLAKE2B 2e3a887dab21d925c30401901fd538d506bfe2a149c5576d6e12007a371e7aa9287e1fac8dd6b918482a31134e82a9c1729e381f8b8cc088f74d1321a113c932 SHA512 f5daef5a4f5c9123add376ac20a62f7a901a6a55a36f0a9e491fdf37b005a2830e47f856939e274b3a24fa0559ddb31dea7cb8b1356214081609d49e2fc051e5
MISC metadata.xml 345 BLAKE2B b168c40ceb66cfacdb1fbe9b5031705f5c3249afeb872163663564dac2ea85e6fa857804831a80b4c44323223b417a24a156d27f8231396d5b090e44a0dc9288 SHA512 e0cbeec10fb47ace3d0fd3c1ba8a5a0bba02345a3e0df30aa82777507fb6ab75f2705b06e7635a00406d2b0839bc41d0a9fafcd8926844e1d9877b8cf2ed6f78
diff --git a/sys-apps/acl/acl-2.3.2-r2.ebuild b/sys-apps/acl/acl-2.3.2-r2.ebuild
new file mode 100644
index 000000000000..d0791550bd1d
--- /dev/null
+++ b/sys-apps/acl/acl-2.3.2-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool multilib-minimal
+
+DESCRIPTION="Access control list utilities, libraries, and headers"
+HOMEPAGE="https://savannah.nongnu.org/projects/acl"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+ GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls static-libs"
+
+RDEPEND="
+ >=sys-apps/attr-2.4.47-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ # bug #580792
+ elibtoolize
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ --enable-largefile
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ # Tests call native binaries with an LD_PRELOAD wrapper
+ # bug #772356
+ multilib_is_native_abi && default
+}
+
+multilib_src_install_all() {
+ if ! use static-libs ; then
+ find "${ED}" -type f -name "*.la" -delete || die
+ fi
+}
diff --git a/sys-apps/ipmiutil/Manifest b/sys-apps/ipmiutil/Manifest
index 0467fa95713b..73a4b4214340 100644
--- a/sys-apps/ipmiutil/Manifest
+++ b/sys-apps/ipmiutil/Manifest
@@ -1,5 +1,7 @@
AUX ipmiutil-2.9.9-lib_symlink.patch 468 BLAKE2B d24e4e0183f46a3a97b9a9db754b4948446eda7504d81b3854cf8ae65eebdc2f279272ecf09736ff2966dfd477219e19a900cce8665f865bc22a8674ea863f2b SHA512 35912b578b3e61e899f97d2fc6cd6352ac04da638c64c252aa71138d9b7fd1b1de474f2702febfb85ab3f5371971be7a1922a1c6bbe5960c04be2b9171f0e75e
AUX ipmiutil-3.1.8-fix-configure.patch 5520 BLAKE2B 62a2f71824c37015e9b5999acaa06780a9e398b4ba74461cb963375c497c0c18e5cbb4b5188aaa5d34521ac0a2153835fda38ffe80a1414d85ecc96da49d114e SHA512 13e58b8516ade13d907462b0eca9ce639ea486740992e1d2f348f17a9ed8deadd1ca7ab0fb2c725e5721f7840119fc5e9b134a8eb842d661d81041f39dd1f6cc
DIST ipmiutil-3.1.9.tar.gz 1876478 BLAKE2B ddbd4d91d1d09fd9a7d4f7a3f9358787cab1baf3e2f34e43b4ebf44843d9ccc8d8b241b030d0f62a4b183ac4642c6676b304a51b8c6611f69d475dd19c1d3181 SHA512 3c9f60669dd6769dc64977c99d68fc0a0838993fb5ef3d8b1b1026b6daf6e6bfbe8738f3dd120b116fc663c84bafe6ed93420a92fecf57a17785d283b415d9c7
+DIST ipmiutil-3.2.1.tar.gz 1745071 BLAKE2B dab369c727a48ae517c1028ef2d68164e980744ef1809e09f9e8d92fcbbdb311d9aaf8efc5477b26d322c65741b104fb0442976e876778c03ca8b6b68026ba28 SHA512 ddb8cee46306c06ef9f0daa6298e1ef92523b050a036beb7230973f1e0ab7cd8e3576202fc6d76fc80a39f57d4ac3c79210dfffe5b486bb11467b53597ce6a6a
EBUILD ipmiutil-3.1.9.ebuild 2221 BLAKE2B c54b95f40e8086ca88f21d232a488730a91b3ccbaafed86d754c8ef8744a2ac7b739871e898c63f811a5d5c8345557f8ad450421b7fed8004d9f9ebb663c78dd SHA512 b90dbb898908788a0d8b6784d2125a6512ac388a3c8adcbde2c2aac99fae8d07c233690d347232d218191cc656ed8a2aa14bf829d6698a412799bc5dcbf4b82d
+EBUILD ipmiutil-3.2.1.ebuild 2084 BLAKE2B e640841d1f4ef6337415070f825d96f31f180baf0be5ac11ea8b0f358a24a470da26ca02f32cb2ea00138ed3e8388b90776665ca84dced4eede673a858bd4c20 SHA512 0f8af1dbb74fc2345cb0dbd8f3745115ff7ea48aff886ba14d1f3d90007ecf1a19d8b9b1bc6c3f9b91c7cc755f93960689a3d3a120f83922af3629a948c89ad6
MISC metadata.xml 395 BLAKE2B bbc505300e1bb4a974b8c5f19c43fe9cbfe4300c31a5174adad799cac0d2507e231845ab8f586ca427538b67ad45012aec660692f1a4a134af4e7615467b0ee0 SHA512 170e9a7718037935d373ad84c37f7c87764e30fdb1c2860fa3021021f91dd94adb2d3acb4adfc5cea8d64a7e612340a2286c5a4748f91ed32d603b9c306f3513
diff --git a/sys-apps/ipmiutil/ipmiutil-3.2.1.ebuild b/sys-apps/ipmiutil/ipmiutil-3.2.1.ebuild
new file mode 100644
index 000000000000..db63f0c238b2
--- /dev/null
+++ b/sys-apps/ipmiutil/ipmiutil-3.2.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="IPMI Management Utilities"
+HOMEPAGE="https://ipmiutil.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/openssl-1:="
+DEPEND="
+ ${RDEPEND}
+ virtual/os-headers
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.9.9-lib_symlink.patch
+ "${FILESDIR}"/${PN}-3.1.8-fix-configure.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix hardcoded CFLAGS
+ sed -i \
+ -e 's|-O2 -g|$(CFLAGS)|g' \
+ -e 's|-g -O2|$(CFLAGS)|g' \
+ util/Makefile.am* || die
+
+ # The configure script makes some guarded and some blind calls to rpm &
+ # rpmbuild, that trigger sandbox warnings if rpm is installed in Gentoo.
+ sed -r -i -e 's/which rpm/false &/' configure.ac || die
+ sed -r -i -e 's/`(rpm|rpmbuild)/`false \1/' configure.ac || die
+ # Don't try to inject -O2 or hardening flags (which we set in the toolchain).
+ sed -i -e '/CFLAGS="-O2"/d' -e '/cfhard=/d' configure.ac || die
+
+ # Don't compress man pages
+ sed '/gzip -nf/d' -i doc/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-systemd
+ --enable-sha256
+ --enable-lanplus
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # Ugly workaround. Upstream is misusing the make system here
+ # and it doesn't even work.
+ # Please check on each bump if this workaround is still required.
+ # Yup, still needed in 3.18
+ pushd lib/lanplus &>/dev/null || die
+ emake
+ cp libipmi_lanplus.a .. || die
+ popd &>/dev/null || die
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" sysdto="${D}/$(systemd_get_systemunitdir)" install
+ dodoc -r AUTHORS ChangeLog NEWS README TODO doc/UserGuide
+
+ # Init scripts are only for Fedora
+ # TODO: ship OpenRC systems for non-systemd?
+ rm -r "${ED}"/etc/init.d || die 'remove initscripts failed'
+
+ # --disable-static has no effect
+ if ! use static-libs ; then
+ find "${ED}" -type f -name '*.a' -delete || die
+ fi
+
+ keepdir /var/lib/ipmiutil
+}