summaryrefslogtreecommitdiff
path: root/sys-auth/pam_p11/pam_p11-0.1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_p11/pam_p11-0.1.6.ebuild')
-rw-r--r--sys-auth/pam_p11/pam_p11-0.1.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-auth/pam_p11/pam_p11-0.1.6.ebuild b/sys-auth/pam_p11/pam_p11-0.1.6.ebuild
new file mode 100644
index 000000000000..b3747044554b
--- /dev/null
+++ b/sys-auth/pam_p11/pam_p11-0.1.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit pam
+
+DESCRIPTION="PAM module for authenticating against PKCS#11 tokens"
+HOMEPAGE="https://github.com/opensc/pam_p11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="virtual/pam
+ dev-libs/libp11
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ dopammod src/.libs/pam_p11_opensc.so
+ dopammod src/.libs/pam_p11_openssh.so
+}